Cfw 5.12 blocking downloads from FileHorse

I have been trying to download programs from FileHorse:

for the past week or so, but Cfw 5.12 is bloking the connection. see images The last time I downloaded a program was like 3 weeks ago and I did not have problems. My firewall got FF set as a Web Browser. Anybody else having this problem ? Can any one try it out ? I tried to download Skype, Comodo, Avast!, and others and failed. BTW I tried it with IE and also failed.

Is it a FileHorse problem ? A problem with my Cfw 5.12 ? Do I add that rule to FF in the firewall ?

Thanks in advance.

[attachment deleted by admin]

I gave it a try and downloads are blocked for me too.

Web-browser policy destination port 88 is not an HTTP port-set component.

Easy fix: add port 88 to HTTP port-set. That allows implicit connection to any IP address port 88 by any web-browser policy’d app

More secure policy: create allow rule for FileHorse IP address that allows destination port 88 explicity for only those apps that need it.

Thanks WxMan1.

That’s what I figured. Added rule to IE and left FF as a Web Browser. What I can not figure is why FileHorse changed port. I have been downloading programs from there a while back and my FF always been set as web browser in Cfw. Well go figure.

Thanks again.

FWIW: check out my last post on this thread:;msg695836


Thanks again. A little elaborated for my taste and day to day use of the web though, and for me running 5.12, well, Cfw 6 and 6.1 did not run in my sys. Cfw 6.2 is almost there but not quite. Still some lagging opening app or running them. I don’t know may be it is time to get rid of this work horse an buy me a new one ;D