cfpupdat.exe error: unknown software exception

A. The bug/issue

  1. What you did: nothing
  2. What actually happened or you actually saw:Update program error. Therefor, an error dialog box popup when CIS update automatically or manually
  3. What you expected to happen or see:nothing but an error dialog box.
  4. How you tried to fix it & what happened: Completely uninstall CIS(including using the uninstaller tool.exe) and download&install the latest version. Shutdown all programs that may cause conflicts include Mactype/Soluto/ProcessLasso. But nothing changed.
    Tried to run the cfpupdat.exe directly from the install directory. Looks like it works!
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: No
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):No
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Everytime when CIS update automatically or manually
  8. Any other information (eg your guess regarding the cause, with reasons): I guess the main program call the cfpupdat.exe in an incorrect way…

B. Files appended. (Please zip unless screenshots).

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
  2. Screenshots illustrating the bug: I use simplified Chinese OS. The title means: cfpupdat.exe Application error. The content means: Application error occurs unknown software error exception (0x0000409), location is 0x400713b0. To abort the program, please press “OK”. To debug the program, please press “Cancel”.
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: Screenshot
  2. a) Have you updated (without uninstall) from from a previous version of CIS: Yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+=Safe mode , Sandbox=Disabled , Firewall =Safe mode , AV = None I think there’s nothing to do with this…
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 with SP1 x64 version (Simplified Chinese OS), default UAC settings, administrator account
  7. Other security and utility software currently installed: None
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box): I have VMware Workstation 8 installed on my computer but CIS is installed in the host

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

  • B.5. Sandbox and AV security levels

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


Information below has been add to the post:
Actually I never use the Sandbox and the Sandbox level is Disabled. And I don’t have any anti-virus software because I think COMODO Firewall can defend all threaten.

OK yes you have the firewall only version, sorry.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again