cfpres.dll error with v.

I was going to post again in this thread but for some reason I can’t reply to that thread anymore. ???

In short: I got another cfpres.dll error, very much like the one I reported in the other thread. System setup is the same as what I posted in the other thread, except that I’m now using v.

Key point: I did NOT get the error upon booting up my machine. Instead, it happened when I was starting to install a Windows Defender update. I don’t let Windows do updates automatically, and so Windows Defender updates need me to initiate the download and then the install process. The CFP error happened just after I had started the WD update install process. As noted in the other thread, I got the error before when installing a Quicktime update.

The first error message said “Error 0x0: failed for …\Application Data\Comodo\Firewall Pro\Data\ResFiles\fw_alert_yellow_L.png”

The second error message said “ERROR: Error while extracting resources from C:\Program Files\Comodo\Firewall\cfpres.dll . Aborting application”

After the second error, CFP killed itself. :o

The error happened yesterday morning; I installed the update two nights before that. I think there was one other Windows Defender update between those two events.

I"ve gotten the same error with two seperate clean installs withing a few restarts. It’s becoming a big issue. Comodo is failing to start pretty much every time. What is causing this?

This happens at boot up.

Any word on this? It seems like an issue a lot of people are running into.

happened to me too this night ( not at boot up but when i see it in the morning :cry:

firewall just disappeared :o and left my computer without protection all night :-\

Can you do something about restarting the firewall manually when this type of errors occur?


and my computer now is infected with a trojan

It would be great if we could get a response from someone at Comodo about this? It seems like a major bug.

yes please

the comodo forum is great but i cant understand why anybody from comodo says anything

Still waiting on some type of response, thanks.

Following is the reply I got from the technical support dep. of COMODO.

Please do the following to Manually uninstall CFP:

Do the following steps in Safe Mode(Press F8 when the system boots up
to login to the Safe Mode):

Step 1: Disable the firewall by right clicking firewall icon on the
system tray and select Exit

Step 2: Disable the comodo helper service

  • Click->Start->Run-> type services.msc…
  • On the services window Right click on comodo firewall pro
    helper service-> Properties ->Disable

Step 3: Open Registry and delete the following entries. Before doing
this please take a backup of the registry through file-> export.

*Right click and Delete the entry COMODO Firewall Pro under
Right click and Delete the *entry *Firewall Pro *under
*Right click and Delete the entry *1 under

Step 4:Restart the system

Step 5: Go to the Installation Folder C:\program files\comodo\ and then
delete the Firewall folder

Step 6: Delete the file *guard32.dll *under C:\windows\system32\

Step 7: Delete the following files cmdhlp.sys, cmdguard.sys and
inspect.sys under C:\windows\system32\drivers

Step 8: Delete the 'Common’ and ‘Firewall Pro’ folders under
C:\Documents and Settings\All Users\Application Data\comodo

Step 9: Delete Firewall Pro folder under C:\Documents and
Settings\Administrator\Application Data\Comodo(Administrator can be
your user account name or the user account through which CFP is installed)

Step 10: Restart the System

Install the new CFP

I hope this will resolve your issue.
Technical Support

I got the same error now :frowning:

Thanks everyone. I have forwarded a link to this thread to our developers for review.

hey everyone

i get similar errors after logon. heres a temporary solution that may work for many of you until developers find a way to fix this properly. seems that this version of Comodo cant always handle loading so early in the boot process… you can untick Automatically start the application… under Misc->Settings. Navigate to All Programs->Startup, right click, choose Open all users and paste Comodo shortcut there. If you want it to start minimized to system tray - go to shortcut properties and under Target add -h like this: “C:\Program Files\COMODO\Firewall\cfp.exe” -h


Hi Guys,

This happens when something intercepts CFPs ability to extract its files on the fly. It may be because of an AV blocking one of the graphics files or a file system failure.

First please scan your disks for errors to see if anything is wrong with your filesystem. If the issue persists, and your filesystem is FAT, in the most cases, converting FAT filesystems to NTFS filesystems would provide a better filesystem and remediate the issue.

Note that this is most probably related to an AV software(Or similar) blocking CFP to create its resource files.

We would really appreciate if you are able to play with your AV software and try different scenarios.

Ofcourse we will be working on the issue and fix if there are any issues.


I have only got this error once…

Hi Guys,
We are coming up with an update this month to minimize the possibility of this error. Although file extraction is simply creation of file operation, but we have added extra checks to ensure that there are few re-tries and additional checks before we really decide to abort application.

Will update here to everyone to re-try once we have update out.


If i allow “C:\Program Files\COMODO\Firewall” to my antivirus and antispyware, so it skips the files in real-time, can that help on this error ??

Hi oOeagleOo,
Please test with latest update and letus know if you still see the issue.


I have updated it to that version.

I have only got the error 2 times, but i will write if i get it igain.

(i havent got it after i updated)