CFP + Vista = No admin privs

after i installed the COMODO firewall i cant run any program on my computer without right clicking it and selecting run as admin.

if i try to run a program normally i get the error - “Windows canot access the specified device, path, or file. You may not have the appropriate permissions to access the item.”

is there anyway i can fix this and keep the firewall?

What mode have you got Defence+ set.
I have had problems with system restore and defrag not running nothing in the defence logs blocked so I set Defence+ to Clean PC Mode which cleared these problems.

defense + is set to clean pc

ive been told that it is buggy for vista and that i should use 3.0 or earlier

i looked for 3.0 but couldnt find it … can anyone point me in the right direction

Are you using version You can go to miscellaneous/about to see the exact version. Don’t use the update procedure; there are still some problems with it. Go to and download the complete version, not the patch, and do the uninstall/reinstall per the instructions there if necessary. How are you logged on to Vista?-as a user or and admin? I am using the latest version with Vista Ultimate with no problems, What other security software are you using?

i was using avg too but thats it.

i am the only account on my computer and its an admin account.

i didnt update… i downloaded from the website and installed

nothing on my computer runs on startup except a spy ware program but i got rid of it. i need to right click run as admin for everything i want to start

im using

is there a link to just 3.0 ?

3.0 is just the generic name of the latest version 3.0.x. Have you made any changes to the CFP3 settings? Look under D+/advanced/image execution control settings and be sure the slider is set to “normal”. To see if it is a Vista UAC conflict, go to control panel/user accounts and turn off UAC temporarily and see if the problem goes away. If none of these work, I would suggest an uninstall and reinstall of CFP-there have been some problems that appear to be connected with the load sequence of the various programs at startup that are still being chased.

i tried turning off user account control before but that just made it impossible to run anything because it could not then ask the admin if it was okay to run… just now i right click run as admin then i get the pop up asking if its okay to run this and i say yes… and it runs…

the slider is set to normal… ill try a reinstall

ive uninstalled and ive got control of my computer back lol … should i go ahead and install the same version?

Yes, if it is we should try again. Could just be a bad install, since haven’t seen this problem before.

well … problem solved… strange…

hope it doesnt go back to what it was like before lol

Our experience is that once one of these apparently loader related problems is fixed, it seems to stay fixed. Can particularly be a problem with Vista, since boot.ini file is gone and it is much more difficult to control the boot sequence than in XP. Let us know if other problems show up.