CFP V3 configuration all lost

Hi folks.

Weird thing happened today, after 3 days of getting absolutely Inundated with popups for CFP to learn my system, yesterday was fairly quiet as I had pretty much opened and run everything I normally use, so CFP had learnt much of what it needed it seemed.
This morning tho, I had to start from scratch pretty much again! All the things I had taught CFP seemed to be lost and I was bombarded by the same popups again asking all the questions I told it to remember before.
Now, I don’t think this is Comodo’s fault tho, as it seems like every week or so I have to re-login to all my sites because my cookies seem to disappear. This has happened well before I installed CFP, so I think that whatever is screwing around with my cookie config also hit Comodo. Another funny thing, when I check my cookies after this happens, they’re all still there, they just don’t seem to be recognized anymore, and it almost seems like that’s what happened with Comodo settings today too.

I thought before that maybe Vista had a scheduled Disk Cleanup by default, but that wasn’t it. All I could find was that Defrag is scheduled to run on Wed evenings, basically 1am Thursday Morn. Defrag shouldn’t do that to my stuff…but it just may be the culprit.
Has any other Vista user seen this same behavior, where your website logins are not remembered, Google preferrences lost, and possibly settings in CFP lost to?
Am I missing something that Vista has scheduled by default somewhere that’s running weekly? Can’t find anything in Scheduled task if there is something in there that’s causing this…



Don’t know about the vista stuff, but the CFP V3 Alpha 1 (and possibly the second alpha as well) has a bad habit of dropping (or refusing to read) the policies and rulesets. Part and parcel of testing alpha/beta software, unfortunately.

One workaround that some users have reported as working is to install CFP V3, set up your policies and immediately backup the registry keys (HKLM/System/Software/Comodo/Firewall Pro - this is from memory, so check it first ;)). If your instance of CFP V3 forgets things, set the protection levels to ALLOW ALL and exit the firewall. Remerge the REG file and restart the firewall.

No guarantess that this will work on your speciifc system, but it’s worth a shot.

Let us know how this works out for you.

Ewen :slight_smile:

Something I’ve tried which seems to work when CFP forgets what it has learned is this: I run all my regular programs (i.e. browser, email client, AV, etc) and, after CFP has relearned them, I exit CFP manually and restart it manually.

Hope this helps.

Thanx Folks!

I thought I’d try to backup (copy) the Comodo hidden files, since that’s usually where all the config data is stored, and try replacing those if it happened again.
I’ll search in the registry for any Comodo keys “panic” and see what may need backing up in there as you mention.

Yah, Alpha/Beta stuff is fun!! I’ve done this type of thing for years and I still enjoy helping find little crawly bug thingy’s, so we can help the developers squarsh em…
So far tho, I LOVE this CFP3, and once we go Beta and get some more options turned on, this thing will seriously Rock!



Have a look at

This is the CFP V3 version of Rotty’s backup script.

Ewen :slight_smile:

[i]don't[/i][/size] panic]One workaround that some users have reported as working is to install CFP V3, set up your policies and immediately backup the registry keys (HKLM/System/Software/Comodo/Firewall Pro - this is from memory, so check it first
Yep, that's where the li'l yummies are located alright...


PS: I like that, “refuses to read” the policies. That’s what I’ve seen several times - the rules were there (in the registry); it just wouldn’t access 'em.