CFP icon is not shown in tray [Merged Threads]


I just switched from ZA Pro to Comodo Firewall Pro but I have a little problem.

When booting the pc (Win Xp Pro SP2) I can not access the GUI of Comodo. The services are loaded and the firewall is working (learning mode and popup for every program connecting to the internet).

Both services cfp.exe and cmdagent.exe are visible in the Processes tab of the Task Manager.

When I check the registry key HKLM\software\microsoft\Windows\CurrentVersion\Run the entry “C:\Program Files\COMODO\Firewall\cfp.exe” -s is there.

When I log of the current user log in again with the same user the GUI is available.

Any idea how I can fix this?

So you are saying that if you double-click on the systray icon that the GUI does not open?

When you boot and the firewall gets started then you have to use the systray to open the GUI as the icon on the desktop does nothing unless the firewall is not currently running.

This is by design as Comodo Backup operates the same.

Now if you are saying that you can’t open it at all from the systray icon with that account then you would need to post that bug in the buglist thread and give your OS and any other security software installed, plus how to recreate the problem, so the devs can see it.


The Comodo icon doesn’t appear in the systray.

There is a desktop icon but when doubleclicking it nothing happens.

After logging out and logging back in the icon appears in the systray and clicking it opens the GUI.

I have Symantec Antivirus

Ok if I am getting this right the first time you log in the systray icon is missing but if you reboot then the systray icon is there?

Does Symantec have a registry feature that could be blocking something there? I don’t have Symantec and haven’t used it in quite a while


It happend to me in previous beta. CFP.exe was running but I had no tray icon.
Killing explorer.exe and launching it again solved the issue.
Another way is to logoff and logon again (without reboot).

Found it in another thread…

Killing CFP.EXE and double clicking the desktop CFP icon also works.

Yep that’s right but if this happen it means that Comodo Firewall Pro policy protection setting was modified or is not working. It is not possible to kill cfp even if task manager has a trusted policy.

cmdagent cant be killed but cfp can. hmmmmm?

Yep that’s strange as they share the same protection settings :o

I will try this this evening.

Killing CFP.exe isn’t possible

ok little update.

I came home and booted my computer. Since I was still doing some other stuff it ■■■■ some time (few minutes) before I gave in my password to logged on to Windows.

Once logged on I noticed that the Comodo icon was in the systray and I could get the GUI by clicking the icon in the systray or the desktop icon.

Let see what happens next time.

I have been running version 2 on one computer and recently updraded from version 2 to version 3 on another. I like the software very much!

Today I tried to update my version 2 machine to version 3. I was asked during the update if I wanted to remove version 2 - answered yes and rebooted. Installed version 3.

Version 3 was running (it produced all the expected messages about runing programs) but there was no icon in the tray.

Clicked on the Desktop icon and again no visible window.

Removed it and reinstalled – same result.

This leaves me with an operational firewall I can’t configure - I chose all the advanced options as configuring networks is what I do for a livinf.

Reverted to Version 2 for now but I want to be able to recommned this firewall but for now I will have to hold back. Note that I provide techical support to a local computer club and have already given this product a tentative recommendation. I also am a professional IT consultant who is often asked for advice for both home and professional use. For now it has to be stick to what you have or try version 2

I can attach sceenshots because if I could see the GUI screen I wouln dot be posting!

The title of this thread should have included NOT!!

By the way Terminal Services is running

Installed CFP_Setup_3.0.19.318_XP_Vista_x32.exe with D+ and it ran well after first boot.
But now I cannot access the GUI. The ruled defined earlier work well. But since I cannot access the GUI I cannot change any. No icon is seen in taskbar. Clicking on start menu doesn’t start it. And it is refusing to uninstall even through Add/Remove.
I am using XP/SP3. Any Help would be appreciated.

You said xp SP3. That sounds like it is a custom version of windows correct? Some reg tweak, or tweak in general to your custom version of windows may have impeded the installation of CFP. The best thing to do (assuming you have the custom version of windows) is to system restore to before you installed CFP. If that is not a custom version of windows (then how the hell did you get it so early) then it does not support SP3 (which isn’t released :wink: )