cfp froze

Hi everyone!
Cfp.exe always freezes if I turn Defense+ from “Paranoid Mode” to “Disabled” when the CPU usages was high at that moment (for instance, a P2P downloading application was running).
And Comodo seems block all requests since then, and I have to kill the process of cfp.exe first and then restart or log out my computer.

(OS:Windows XP SP2/SP3,Comodo Firewall Pro version: from previous versions to

Hi kos2007,

First off all… Read this:

Good information on there, and I recommend you use Clean PC Mode or Safe Mode:

Safe Mode: While monitoring critical system activity, the firewall will automatically learn the activity of executables and applications certified as 'Safe' by Comodo. It will also automatically create 'Allow' rules these activities. For non-certified, unknown, applications, you will receive an alert whenever that application attempts to run. Should you choose, you can add that new application to the safe list by choosing 'Treat this application as a Trusted Application' at the alert. This will instruct the firewall not to generate an alert the next time it runs. If your machine is not new or known to be free of malware and other threats as in 'Clean PC Mode' then Safe Mode' is recommended setting for most users - combining the highest levels of security with an easy-to-manage number of Defense+ alerts.

Clean PC Mode: From the time you set the slider to ‘Clean PC Mode’, Defense+ will learn the activities of the applications currently installed on the computer while all new executables introduced to the system are monitored and controlled. This patent-pending mode of operation is the recommended option on a new computer or one that the user knows to be clean of malware and other threats. From this point onwards Defense+ will alert the user whenever a new, unrecognized application is being installed. In this mode, the files in ‘My Pending Files’ are excluded from being considered as clean and are monitored and controlled.

However, Is there a reason why you set it to disabled?


Thank you for your quick response! Josh!

Actually, I think I just report a bug here.

It is due to other reasons for me to disable D+ and I just found cfp fails at such a occation.

Furthermore, under high CPU usage occaions, cfp may also fail even when I turn D+ from “Paranoid mode” to “Traning mode”, or “installation mode” instead of “Disabled”.

For quite a few previous versions as well as the 349, I can confirm this issue.



I thought we solved the CPU issue. Anyway, There is a new release coming very soon… Like in 24 hours time. If you could uninstall your current version and install the new version when it’s out, Then post back, that would be great.

Just be patient :slight_smile: We will see how things go!


firewal detected updates this norming…

i have choosed not to update becuse i have the latest build…

now i try to update again and says that doesnt have an update

some bug in the server i supose ???

Excellent Job! Version 368 solves my problem now!
Thank you so much, Comodo team! :BNC