"cfp.exe not responding" on WinXP shutdown [Issue Report]

Sometime “cfp.exe not responding” on WinXP SP3 (latest patches) shutdown (about last half year, during this time Windows reinstalled on formatted HDD, CIS Firewall only through clean install)

The bug/issue

  1. What you did: Start->turn off->turn off (after browsing with Firefox, chatting, playing WoW)
  2. What actually happened or you actually saw: window about waiting for termination cfp.exe
  3. What you expected to happen or see: pc turned off
  4. How you tried to fix it & what happened: in february reinstalled Windows XP and CIS
  5. If its an application compatibility problem have you tried the application fixes here?:
  6. Details & exact version of any application (execpt CIS) involved with download link: intact AVG antivirus, installed only Firewall from CIS (no antivirus confilcts)
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: about 30% when turning off PC
  8. Any other information (eg your guess regarding the cause, with reasons): have Win7 on same PC, another HDD, there Comodo Firewall + AVG works without problems

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: cant make screenshots or else since PC at this stage almost turned off
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:
  2. a) Have you updated (without uninstall) from CIS 3 or 4: since february fresh install with hdd format, clean install, issue remains
  3. a) Have you imported a config from a previous version of CIS: no
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= not installed, Sandbox= not installed, Firewall = Comodo, AV = AVG
  6. OS version, service pack, number of bits, UAC setting, & account type: MS Windows XP Pro (5.1, version 2002, build 2600), SP3, latest updates,
  7. Other security and utility software installed: none
  8. Virtual machine used (Please do NOT use Virtual box): not used

I have been a longtime user of this wonderful product on my XP machine,but had to uninstall today because the OS locked up (CPU resources maxed out). After uninstalling Comodo, everything is fine again.

This started happening since the updates were issued the past couple of days.

CIS can have a problem with Uphclean.exe, a service that XP users commonly run.

Strangely CIS can have problems a) if you run it b) if you don’t, according to your machine and the CIS version.

So I’d try a) stopping it and disabling it from starting B) installing it if you don’t have it. (Make sure yuget it from an MS or other trusted site).

For the last version of CIS on my machine I had to disable it.

Basically XP shutdown is somewhat broken at the ‘save user profile’ stage. Uphclean is a cludge to fix this, but only a cludge.

If you need help on how to stop/disable a service please ask.

However I think this is an unreported bug. So if my fix solves it please add the approprioate info to your report.

Best wishes

Thanks. It was not installed (system was quite clean without any tweaks). I downloaded it and installed. Will see is it helps.

Thank you for your Issue report it does lack some information.

It is always best to supply a full report Example here.

Moved to verified.

Thank you


I’ve used report example. Do you need more? What exactly? Shutdown time when almost everything closed isn’t best time to make screenshots or whatever. Had this issue several months but when you shutting down PC it is not good time to make reports.
Anyway after installing Uphclean 2 days I had no problems until yesterday (same happens).