CFP.exe crashes when used with Sandboxie and Eicar testfile [300]

I am posting because i received this pop up (screenshot).

The bug/issue

  1. What you did: I was using sandboxie and downloading the eicar file. I got a notification of the antivirus and ignore it and then tried to execute the file within sandboxie. Then i got a 2 pop up from Defense+ wich i first allowed it and later runned the file again and blocked the pop up of Defense +.

  2. What actually happened or you actually saw: When i closed sandboxie, (but not deleted the contents of it, nor terminated), CIS5 terminated (at least the GUI) and i got that screenshot of the error.

  3. What you expected to happen or see:

  4. How you tried to fix it & what happened: I just restarted Comodo and it worked. The eicar file was in the sandbox and it was scanned on line and then deleted (screenshot 2). if i am not mistaken it did that after i deleted the contents of the sandboxie.

  5. Details (exact version) of any software involved with download link: eicar anti-malware test file

  6. Any other information you think may help us:

Files appended

  1. Screenshots illustrating the bug: yes
  2. Screenshots of related event logs or the active processes list: yes
  3. A CIS config report or file.
  4. Crash or freeze dump file: yes

Your set-up

  1. CIS version & configuration used: CIS 5.0.162636.1135, proactive
  2. Whether you imported a configuration, if so from what version: no
  3. Defense+ and Sandbox OR Firewall security level: Defense + and firewall in safe mode,sandbox enabled
  4. OS version, service pack, no of bits, UAC setting, & account type: windows 7 home premium 32 bits, UAC in default configuration, administrator (account)
  5. Other security and utility software running: Sandboxie, malwarebytes SAS and Hitman pro on demand.
  6. CIS AV database version: 6204

[attachment deleted by admin]

THanks for an excellent issue report, forwarding now.

Best wishes