CFP/Defense+ block AntiVir updates?

I’ve had some problems with updating Avira AntiVir. When I click to update the program, the usual update window simply doesn’t appear. It notes that “Job started” under events, i.e that I clicked to update, but then nothing more happens. I have a hard time finding the reason behind this, so I would like to know if CFP or Defense+ may have something to do with it. If so, then what, and what can I do to solve it?

And even if you don’t think CFP or Defense+ is involved, but has an idea of what else it might be, then you’re most welcome to tell me that.

Thank you.

Have you checked you firewall log and D+ log to see if Comodo indicates it is blocking anything? Are you running What OS are you using?

For what it’s worth, I’ve not had that problem here, using D+ in “Clean PC” mode, and the free version of Antivir Classic.

Same here. Look in the logs for whatever got blocked. I’ll tell you my D+ settings:

sched.exe has permission to run (“as executable”) preup.exe
preup.exe has permission to run update.exe
update.exe is treated as installer/updater

This should do the trick. The first two settings were learnt by D+'s clean pc mode.

Do you have any rules in" application rules "set up for Avira?
I have 2 which are:
C:\Program Files\Antivir PersonalEdition Classic\update.exe Trusted Application
Allow all Incoming and Outgoing Requests

C:\Program Files\Antivir PersonalEdition Classic\avnotify.exe Custom
Allow IP Out form IP any to IP any where protocol is any

Nice 1 Matty

Ah yes I forgot about the firewall, of course you need outbound access for update.exe, I myself have assigned the Outgoing Only predefined policy and it’s enough.

I tried to use Antivir on my Vista machine. The update didn’t work and the problem was apparently caused by my using the Norton removal tool. This had removed part of windows needed by the updater. I was not able to repair it so changed to AVG.

Thanks for the replies. I didn’t find any indication that Defense+ blocked AntiVir updating in the “Wiew Defense+ Events”.

This problem occurred after I ran Norton Removal Tool (presumably there were some rests of Norton left in the computer). Before that, things were fine, updating worked excellent. I can’t see how it would be connected to this, but I better mention it at least.

I had already started writing my post, so I didn’t see this one, sorry.

Ahh yes! That’s what I mentioned. And yeah, I’ve Vista too. So I’m not alone in this. Well, I’m extremely happy it wasn’t caused by malware at least. Well, I at least hope it isn’t malware behind.

Norton punishes more unsuspecting customers.


I think a system restore to before you used Norton’s tool should solve anything that was messed with.

I tried to do the registry fix described here:

It didn’t work for me and I had moved on too far from the restore which would have probably sorted it.

Thank you all.

Does Windows make restore-points at a regular basis itself? I very rarely make restore-points on my own accord… (:SAD)

Is there a reason why adding Avira in “Define Trusted Application” is a bad idea?

To be honest, this is my cure-all for most of my similar issues…it has worked more than once.

Perusing the posts I didn’t see it…oh, there it is (riggers)…never mind…

Yes it does. Well when you run as admin anyway. Choose to restore to a previous point and a calendar will appear for you to select.

It seems like this solved it! ;D

I tried to reinstall before I found this one, that didn’t help. But with the registry fix it seems to work :BNC