CFP and MMOs

I’m playing this MMO called 9Dragons, it uses an anti-hack/anti-cheat system called Gameguard(GG). The problem is that whenever I try starting the game (with CFP on), my computer reboots.

I tried running the mode in training mode (both Firewall and D+), it didn’t help… further I put all the game files and GG files in the “Trusted Applications” category, that did not work either.The shocker is that even when CFP is disabled, and I try to run the game, my computer reboots. I disabled cmdagent.exe service and removed cfp.exe from the startup list, restarted and then tried to run the game… again reboot! :frowning:

The only way I can run the game is if I uninstall CFP, then it works fine.

Gameguard is very intrusive, it scans memory to check if other programs do not interfere with game memory, and it checks all applications running in the background with its blacklist. I just hope CFP is not on its blacklist. (Gameguard is known to have blocked certain popular tools such as “Process Explorer” from SysInternals)

Does anyone have any suggestions as to how I can make the game run? Hopefully somebody would have come across this situation (running a GG protected MMO with CFP)

Does CFP make changes to Windows DLLs or anything like that? (the game did not run even when cmdagent.exe and cfp.exe were disabled)

Does CFP have any module running in memory even when the service and program are not running?(maybe GG blocks this module running in the memory)

I hope there’s a solution to this problem, I like CFP and I would very much like to keep using it. :slight_smile:
I would say that it is the best freeware app I’ve laid my hands on since Firefox & UTorrent (:TNG)

Cheers :■■■■

Look here. Already been posted.

Thanks Vettetech, I guess CFP blocks GG because GG indeed displays rootkit-like behaviour, but what puzzles me is that that the game does not work even CFP service(cmdagent.exe) and cfp.exe are NOT running.

The game works ONLY if I uninstall CFP.