CFP Beta Bug Reports (32-bit version) [Closed]

Edit by Moderator:

[b]Please post bug reports for 32-Bit operating systems here.

In your post, please specify:

Operating System (XP, Vista) with full version, updates, etc.
Active (real-time) security software - Name, version, & most recent update
Active system-monitoring or performance-improving software - Name, version, most recent update

Please be as specific as possible regarding the symptoms you have experienced, and steps you have taken to trouble-shoot or resolve the issue.

Thanks for helping with this Beta.[/b]


I found a bug and the problem is: I installed the lastest beta and when I try to get to a website I get a blank page and when I unintall it I can display webpages.

I’m running the very latest beta version in vista and I too get the diagnostics error
but even after a restart/reboot it still reports the error…
is this an actual vista problem or a beta problem?
I took the liberty of saving an error report but am not aware of what to do with it…
can anyone shed any light on this please?


Diagnostics utility reports incorrect issues in Windows Vista and in XP(tested this myself).
Look for the complete list of known issues on the download page.

  • ‘CPF File Submition’ should be a little tweaked. ‘File area’ should be smaller and the ‘description area’ should be bigger;

  • 'Diagnostics’ finds some unspecified problems and cannot fix them ( report attached). It didn’t happen in previous beta;

  • 'Diagnostics’ report should automaticaly adds *.log file extension;

  • ‘Traffic’ in ‘Summary’ is updated too slow, aplication may be closed for a long time and all ‘Active connections’ also but it will be still displayed in Summary / Traffic ;

  • Clicking on system tray icon doesn’t popup CFP GUI if it is already minimalized;

  • Going into Standby Mode(S3) takes few minutes (with CFP 2.4 it takes a few seconds);

  • High HDD activity when scaning ports (Shields UP!! All Common Ports Test );

  • Option ‘I would like to import a safe file list from a file’ uses ‘Save as’ subwindow instead of ‘Open’;

  • Option ‘I would like to submit files to COMODO for analysis’ uses ‘Finish’ button instead of ‘Next >’ button;

  • Rules set in ‘Application System Activity Control’ should be applied and saved immediately after you press apply button in that window and not only if you press apply button in ‘Computer Security Policy’;

  • The ‘Email Clients’ ( predefined firewall rule) seems not to work at all. Also it’s not available to choose it in firewall popup alert; Thunterbird downloads a homepage when it starts by default that’s why I thought it didn’t work.

[attachment deleted by admin]

Cannot disable Image Execution Protection in this build :cry:

Win XP +SP2 (officail release), No any other security softwares, only CFP

I cann’t add a new file type like “*.com” into “My file grounps-Excutables”, also cann’t modify anything in “My file grounps”, cann’t change “Image excution control setting”. cann’t add a new file type into “Image excution control setting–File to Check”.

Still Forget rule. E.g. I let Blackbox as a “Shell Application”, but sometimes the rule changed to “Custom policy”.

Ofcause after you setting , you need to re-run CFp.exe then can find above issues.

Sometime using Emule may cause cfp.exe crash no any notice, when my mouse point to cfp in system tray, it disappear right now.

[attachment deleted by admin]


I’m still having the problem where the “More…” button doesn’t work under “View Firewall Events”. Anyone else having this problem?


Edit: Not sure if this problem is caused by the size of the log. Appears to work the first couple of times (when the log is smaller) and then stops working :'(.

It still need a long time to shutdown my PC . And this :

Try the user profile hive cleanup service from Microsoft:

This usually speeds up shutdown or log off times and should help with your problem - it has helped with similar issues with CFP 2.4.


The “More” button only works the first time for me, and this is consistent. If I reboot, it again works the first time, but only the first time. The log viewer does not remain in memory after this first usage.

As a suggestion, how about adding a “Clear Logs” button to the “View Firewall Events” window?

Ewen :slight_smile:

Thanks for your help , I download the software and install it , when I shut down my PC , it is really faster then before , but I am very sorry to say that it is still very slow , it will take about one or two more minutes , if I exit the CFP , it need only about thirty seconds :-[

Vista 32bit Ultimate.

This install still BSOD’s on me when Defense+ is active, only setting it to Allow All makes my system bootup. I’ve tried the “Set Image Execution Control to Disable” but this doesn’t seem to help.

After reboot in Safe mode the Image Execution Control seems to be enabled again, maybe that’s causing the crash. So for now I’m using the Allow all option.

I can’t find a crash dump for this BSOD, so I guess that it was too low level (or early) for Windows.

I also noticed that when I block an executable in the firewall I still get connection popups for that executable, which seems to defeat the purpose of the option. It also gives me multiple entries in the Applications rules which are all the same.

I don’t think that was the effect this option was supposed to have.

To get LAN printing working, I had to add the following

Allow TCP or UDP in/ out from ZONE to ZONE
Allow ICMP in/ out from ZONE to ZONE

to the “Outgoing Only” definition.

This is despite ZONE being defined correctly and network rules created accordingly using the Stealth wizard.

Without these two additions, printing was stopped by the BLOCK rule for SYSTEM and SVCHOST.EXE.

Ewen :slight_smile:

Updated files are not detected!

After allowing “explorer.exe is trying to execute…” without using the Remember option, CPF doesn’t ask again the next time … is started. This is good; a “session only” option, so to speak.

However, there are two problems:

  • after shutting down and restarting CPF it still doesn’t ask again.
  • there is no indication of a new or modified exe (updated version or compression\decompression)! they just run, no questions asked. Even after restarting CPF it doesn’t work.

A reboot is required in order to “wake CPF up” again. That can’t be right, can it?

XP Pro SP2 version 2002 Build 2600, 32-Bit.
1.6 GHz processor
512 MB RAM
60 GB HD
CAVS, virus db
BOC 4.25, updated 8/24 11:00:31 UTC
CMG Beta

Prior to uninstalling prior Beta, I exported the Global Rules for the FW side (since I have quite a few custom rules for both work & home that I didn’t want to recreate), via Regedit.

After installing this Beta, but prior to rebooting, I reimported that registry key.

Now if I open the Stealth Configuration wizard, it is preset at “I want to be completely visible…” (the first option). I can select any other option and go through the motions with that - it will not create any additional rules in Global Rules, nor will it change the existent rules imported thru the registry.

When I reopen the Stealth Config wizard, it will once again be preset at “I want to be completely visible…”

Is this a bug (surely it must be… :wink: ), or by importing the way I did, have I blown its poor little hard-coded mind?


XP Pro SP2 version 2002 Build 2600, 32-Bit.
1.6 GHz processor
512 MB RAM
60 GB HD
CAVS, virus db
BOC 4.25, updated 8/24 11:00:31 UTC
CMG Beta

From systray icon for FW, I just set FW Security Level to Custom, and D+ Security Level to Ask All. Then I clicked on a link in a webpage. Balloon message indicated D+ was “learning” so I Exited the FW, waited a minute, and restarted from desktop icon.

When the GUI opened, it showed FW at Custom, D+ at Learn All (where it was before I changed it). I changed it back to Ask All and selected Apply.


Me Neither!!!

Oh I forgot!! My machine is terribly slow with defense + running even in learn safe only explorer takes forever to load and this didn’t happen with previous beta… turn Defense + off and everything runs just fine…

just in case you ask it’s not a compatibility problem, I’ve already tried disabling any other software running and still the same slowdown, seems like defense + is not letting anything run untill it has done it’s check, but it takes toooooo long to check…

Excuse me but the Profile hive cleanup is a tool to debug problems with shutdown generated by other software than microsofts.
I’m having the same issue since I installed the new beta, and not even letting csrss shutdown comodo seems to do the trick, I’m starting to believe it’s a bug related to cmdagent or cfp.exe not letting go when they get the kill instruction from the OS.

-Running XP SP2 here-

1)have to reboot in safe mode after second restart, have to de-install CFP to make it normal (:SAD)
2)diagnostic reports error and cannot fixed it

Windows XP SP2 media center edition
other security software : CAVS2.0.15.51, CBO4.25

I am on a double boot (two disks) with XP on the C:\ partition and Vista on H:.

When installing on Vista when the wizzard of the installer checks for known applications it starts reading the C:\ partition instead of H:\ where the active OS is running from.