CF block server port over WiFi while on same system it is open via Ethernet

Hi everyone
https://forums.comodo.com/Smileys/default/smiley.gif" alt=“:)” title=“Smiley” class=“smiley” style="

I just registered on this forum, but I am using Comodo Firewall more than 8 years.

System specification:

[*]Device: HP Laptop with these hardware specifications:

[]Ethernet (wire) - Realtek PCIe EF Family Controller
[
]WiFi - Broadcom 802.11n Network Adapter
[]AMD A8-7410
[
]RAM 4GB

[*]Modem/Router USRobotic 9108

[]4 Ethernet Ports
[
]Wifi B/G

[]Windows 10 Enterprise x64 - v1607 build 14393.0
[
] UAC is completely turned off (registry hack too - all apps run with administrator privileges)
[]Windows Firewall is On
[
]Comodo Firewall 10.2.0.6526

[]Comodo - Proactive Security
[
]Firewall set on Custom Ruleset
[]Checked = Set alert frequency level “very High”
[
]Unchecked = Create rules for safe applications
[*]All firewall Advanced settings checked (Filter IPv6 …)

[*]VMware v14.1.2 installed on the same system:

[]Windows 7 x64 SP2
[
]UAC is completely turned off (all apps run with administrator privileges)
[]VMware network configuration: Bridged (Automatic) - turn off “Replicate physical network connection state” option
[
]A server application that use(Listen on) port 1027

Usage in brief:
(On Guest OS) Running a server app on Windows 7 on VMware.
(From Host OS) From Windows 10, some apps try to access the server on Guest OS via port 1027.
=> Connecting Laptop Ethernet with wire to Modem/Router (WiFi is disconnected): Apps on the Host OS (Win10) [COLOR=#00b050]can access the server.[/COLOR] (Even if Comodo Firewall is enabled)

The Problem:
But when Laptop connects to Modem/Router WiFi (Ethernet cable is unplugged):

[]Comodo Firewall is On: Apps on the Host OS (Win10) cannot access the server! While the IP address of Guest OS (Win7) is ping-able.
[
]Comodo Firewall is OFF: Apps on the Host OS (Win10) can access the server.

Please check my tests on Win10 Powershell while I was trying to check if port 1027 is open on the Win7 IP address:

<< Comodo Firewall is Enabled - [COLOR=#00b050]VM IP is ping able but Port is not accessable>>[/COLOR]
PS C:\Users\User> test-netconnection -computername 192.168.1.101 -port 1027
WARNING: TCP connect to 192.168.1.101:1027 failed
ComputerName : 192.168.1.101
RemoteAddress : 192.168.1.101
RemotePort : 1027
InterfaceAlias : Wi-Fi
SourceAddress : 192.168.1.100
PingSucceeded : True
PingReplyDetails (RTT) : 0 ms
TcpTestSucceeded : False

<< Comodo Firewall is Disabled - [COLOR=#00b050]VM IP is Ping able and Port is Open>>[/COLOR]
PS C:\Users\XxX> test-netconnection -computername 192.168.1.101 -port 1027
ComputerName : 192.168.1.101
RemoteAddress : 192.168.1.101
RemotePort : 1027
InterfaceAlias : Wi-Fi
SourceAddress : 192.168.1.100
TcpTestSucceeded : True

Question: How /Where should I set some settings in Comodo Firewall on Win7 to let apps on Win10 access server port on WiFi!?

I played with Network Zones and Portsets but no luck! I will appreciate any help!?

Thanks in advanced

A long standing bug that probably won’t be fixed anytime soon, current workaround is to add the Windows Operating System to application rules and set it to outgoing only. To do so you use browse > running process and select WOS from the list.

Hi futuretech

Thanks for quick reply! I tested your suggestion and it works! :-TU ;D at the end of this I had a small problem! I will appreciated to check it out. Also beside that small problem, This topic can be lock due to your answer fix my problem. Thanks again :-TU

For future helps, If anyone had the same problem with VMware and WiFi connection, I did this in Comodo Firewall installed on HOST OS (OS on real machine, we do not need to do anything on The Guest OS firewall except regular allow permissions to Server apps! :wink: ) :

  • In Comodo Setting window go to Firewall\Application Rules click on Add button, then click on Browse button and select Running Processes. (Please check attached image)

    • In Browse for Processes window, Select Windows Operating System from top of the list, then click on OK button. (Please check attached image)
    • In Application Rule window for Windows Operating System, Select Use a Custom Ruleset then click on Add button.
    • In Firewall Rule window, change Direction to Out, Type any Description then click on OK button.(Please check attached image)
      At this point, If someone had the same problem with VMware and WiFi connection, by above changes should be okay now! But I like to make more specific rules and not general ones! Therefore, in last step (Firewall Rule window) I add these extra and more specific changes too (based on my Server port and Guest OS computer name):
  • Turn on Log as Firewall event … option.

    • At Source Address tab, changed Type to Host Name and at Host Name text box typed my Guest OS domain name (computer name).
    • At Source Port tab, change Type to A Single Port, then insert 1027 in Port section.

The End! :-La :-TU

Question:
Even by turning on Log as Firewall event … option, I do not see any logs for it!? Is it another bug or …!?

Best Regards
JS