Certificate chain is not validated

Dear all,

I’m trying to sign a jar using jarsigner tool, but i’m getting the warning “Signer’s certificate chain is not validated”.

Kindly guide me to solve this issue.


I’d suggest starting with the knowledge base on code signing:



Dear Guru,

Thank for your reply.

I have tried the same steps that was listed under “Signing JAR Files” topic, but still I’m getting the “The signer’s chain certificate is not valid”.

Kindly guide us to solve this issue.


Since you’ve purchased a Code Signing certificate from Comodo I would suggest submitting a ticket to support as the next step:




Did you happen to find a solution to this issue? I checked through the Knowledgebase articles linked above but did not find anything either. I obtained the certificate via IE, exported including private key to a .pfx, copied the .pfx to my Linux host, verified the .pfx using keytool, and when I run jarsigner, I get the “Warning: The signer’s certificate chain is not validated.” result as well.

I’m not completely sure I can open a Comodo ticket, despite the certificate being authorized by Comodo, it is requested through a third party (InCommon).