CD changes DNS

Guys, please…
I’m fed up with this bug, I don’t understand why you place an option to choose whether use Comodo DNS or not and then let CD do what it likes.
Fix it on the next release or I’ll opt out of CD.

Hi Jon79,
I haven’t seen this occur.
When does this happen and is it system wide or only within Dragon?


I haven’t seen this either and I use CD on multiple workstations. Which version and version number of Dragon (Ice or standard) is being used and on Which OS ( XP, Vista, 7, 8, 8.1, 2003, 2008, 2012)?

It changes my system DNS.
I’m using CD 30 on Windows Vista Home Premium 32bit.
I don’t know if it’s a bug of CD or CIS (I updated both recently), but this has already happened before.
Every time CD or CIS asks me about DNS, I always check “Don’t use Comodo DNS”, but it seems it doesn’t care

Thanks for the reply back Jon79, it would be good to know what program has caused this.
I have a Vista 32-bit system, I might try to reproduce this tomorrow if time permits. :-
I can’t promise any results considering I haven’t seen this before, but no harm in trying.

Did you update existing programs or did you do fresh uninstall/re-install for both or either CD/CIS?


Thanks to you for your help, captainsticks :-TU
I updated both CD and CIS by the automatic update (so, I updated existing programs).
Usually CD doesn’t ask me anything and keeps my settings (at least, this is what I thought), while CIS 6.3.301250.2972 (not sure if also 6.3.302093.2976) asked me about DNS and I chose “Don’t use Comodo DNS”

I just want to clarify something here since I’m not 100% sure what you mean, you do mean that you un-check the option to set up Comodo DNS and not that you check the option to not set up Comodo DNS, right? I hope you understand the question.

During the installation process, it comes with 3 options (I don’t remember if in this order):

  1. Use Comodo DNS everywhere
  2. Use Comodo DNS only on CD
  3. Don’t use Comodo DNS
    I selected the 3rd option (you have to check one, you can’t leave all of them unchecked), but it seems it didn’t work as expected

Ah sorry, it seems I’ve forgotten how the setup does things, thought it was like CIS where you have to uncheck it. (unless I’m wrong about that one too… ???)

Here a pictures to explain.
Of course, I unchecked “Enable malware domain filtering (Comodo Secure DNS)” on my CD

[attachment deleted by admin]

Ah I see, thanks for the clarification. :slight_smile:

I tried to reproduce this by installing 29.1 and then update from within 29.1 and could not reproduce. I am on Win 8 x86.

I see. So, maybe it depends on CIS and not on CD…

Hi Jon79,
Sorry I run out of time today, but when time permits I will install the previous version (CIS) and run the updater to see if the issue reproduces.

It’s OK, captainsticks, I have set up my old DNS, so I should be fine until the next CIS update :slight_smile:
Anyway, if you can share your results, we can see where the problem comes from and ask Comodo guys to fix it :slight_smile:

Hi Jon79,
I have installed the previous version of CIS then run the updater and the issue will not reproduce here, sorry.

I even tried it a second time allowing ‘Comodo Secure DNS’ during the initial install, then manually changed it back to ‘Obtain DNS server address automatically’.
Rebooted and then run the updater for CIS and my manual settings were honoured.

Kind regards.

Thanks for your feedback, captainsticks.
I don’t know, I’ll check again next time either CD or CIS are going to update.
Have a nice weekend

Thanks Jon79,
Yes keep us informed if it happens again.

Thanks from Captainsticks.

Err, if what happens again?.. A DNS change? :-0

… Because, it’s never happened (if options correct).

Just browsing the forums and came across the post… Anyway ^^

Apparently it has not happened again as Jon79 has not reported back. Does the problem happen on your system?