CD 33 prompts for Windows Password to display saved passwords

Specific symptoms of the bug:

When I try to display one of the saved passwords, I get a popup box asking stating “Comodo Dragon is trying to show passwords. Type your Windows password to allow this.”

Specific steps you have taken to try to resolve it:

Logging out, restarting the PC, enabling and disabling “master password”.

Comodo Dragon Version: 33.0.0.0
Plugins/Themes installed:
Myibidder Auction Bid Sniper for eBay 1.3.7
WeatherBug 2.2.7
Windows version: Windows 2003 R2 SP2 32 bit

System Drive: C:
Comodo Dragon installation path: F:\Program Files\COMODO\Dragon
User privileges: Administrator

Google Chrome installed: Google Chrome Portable, Version 29.0.1547.76, no issue

[attachment deleted by admin]

Hi pS_cis,

Go to dragon://flags/#password-manager-reauthentication and enable that flag to disable the feature (yes, it’s a feature, not a bug).

See also: List of Chromium Command Line Switches « Peter Beverloo

Disable the setting to prompt the user for their OS account password before revealing plaintext passwords in the password manager.