CD 29.1 acting Strange

Hi there,

Yesterday, when I was using CD 29.1 I started to run into Problems.

The Problems I found is the Backspace button, at the very top. If I press the Backspace button, it would open a New Tab, and I am unable to view the last page O was viewing. But if I press the Open tab that came up it would shut down.

And CD got very unresponsive so I had no choice in Removing it, Then go over to Internet Explorer 11.

So any advise or a Fix will be good.

Thanks in advance


Mod edit: Corrected spelling in the topic title, Captainsticks.

Hi Nige_39,
Have you recently added or updated any extensions.
Try with all 3rd party extensions disabled.
Note: Not so much in recent versions, but ABP did cause some issues for Chromes back history button in the past.

If the above doesn’t help you could try the portable version, this would eliminate any Dragon user profile issues.
Portable Version

Thanks captainsticks,

The only extension I have only used was HTTPS Everywhere, Privdog and Disconnect.

I will try the Portable version and see how it fairs from the other version.

Thanks again



Hi again,

I have installed the Portable Version, and look better now, also running smooth.

Thanks for your help captainsticks



Hi Nige_39,
Seeing the portable is working fine, something must be astray with your installed version.
Might be worth trying a new user profile for your installed version.
To create a new user profile in Comodo Dragon

Kind regards.

Hello again captainsticks,

What I have done, I Removed the Portable Version, then Completed Removed left over files and folders within C Drive and Registry of CD 29.1 installed version. Then I run a Registry Defrag with CCcleaner. then I booted into Dos then I Ran a Disk check for errors, then system file checker.

Then I came back onto Windows 7 then installed CD 29.1 from filehippo.

Now everything runs smooth again.

So I will hold off from creating a new user profile for now.

Thanks for your Advise

Kind Regards


Hi Nige_39,
That is good to hear that it is running smooth, let us hope it continues to behave. :-TU

Thanks for letting us know.
Kind regards.

Your welcome and thanks 4 your help :slight_smile:

Hi there,

I have a problem using Dragon on windows 8.1 I have a pink hue on all of my pages that i visit.
This only occurred after I upgraded to windows 8.1 from windows 8.0. All of the settings are the same as before. Help it is hard to read the pages and have had to go back to using IE which I hate.

Hi and welcome blazer9,
I have seen this reported to happen a few times now.
The only thing I can think of to try is disabling Use hardware acceleration when available, found at the bottom of Dragons advanced settings under system.

Try updating to version 30.