CCE (Bundled with CIS) Scan Percentage Not Accurate [M120]1[V6]

This bug report is for CCE, which is bundled with CIS.

I run a full scan with CCE, restarting where requested. During the scan the scan percentage quite quickly reaches 49%. This takes only a minute or so. However, from there it very slowly approaches 100%. (I mean very slowly). Obviously something is wrong with the way the percentage is calculated so that it quickly reaches the half-way point, even though only a few files have been scanned.

Therefore, I believe it is a problem and that the scan percentage should be more accurate. I believe this is important, as ordinary users who go to run this may believe the program locked up, or perhaps become very frustrated because of the apparent drop of scan speed.


  1. What you did:
    I just ran a full scan with CCE, starting where requested. I then noticed that the scan percentage very quickly reached almost 50% even though it had only been a few minutes and less than 25 files had been scanned.
  2. What actually happened or you actually saw:
    The scan percentage very quickly reached almost 50% even though it had only been a few minutes and less than 25 files had been scanned.
  3. What you expected to happen or see:
    I had expected the scan percentage to accurately represent the total progress that the scan had made.
  4. How you tried to fix it & what happened:
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (except CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    Just run a full scan with CCE and watch how the scan percentage increases. I can reproduce this each time.
  8. Any other information (eg your guess regarding the cause, with reasons):
    I’m not sure what causes this.
    B. FILES APPENDED. (Please zip unless screenshots).:
  9. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):
  10. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues::
  11. Screenshots illustrating the bug:
  12. Screenshots of related CIS event logs:
  13. A CIS config report or file:
  14. Crash or freeze dump file:
  15. Screenshot of More~About page. Can be used instead of typed product and AV database version:
    Information provided below.


  1. CIS version, AV database version & configuration:
    Comodo Internet Security Version 6.0.260739.2674
    Database 14614
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    No, it is default.
  5. Defense+, Sandbox, Firewall & AV security levels:
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 x64 (Service Pack 1)
  7. Other security and utility software currently installed:
    Just Comodo System Utilities and CCleaner.
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:
    Not a virtual machine.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

This bug still exists in version 6.0.264710.2708. Please feel free to contact me via PM if you have any questions or require additional information.


This is still not fixed with version 6.1.275152.2801.

This is still not fixed with CIS version 6.1.276867.2813.

Tracker updated, thanks

This is not fixed with CIS version 6.2.282872.2847.

The devs have confirmed this behavior, but have decided that it is intended as there is no way to estmate time for different scanners, so they can’t make it accurate.

I’ll move this to Resolved.

Actually, after additional discussions, this has been re-opened. I’ll now move this back to format verified.

Thank you.

The Devs have decided that the amount of effort needed to fix this issue is not warranted by the benefits. Thus, this will not be fixed.

I will move this to Resolved.