CB changes backup destination path haphazardly

Hi (first poster)

I’m running a predefined CBU file for backup from a local drive on to a external harddrive.
It is a incremental backup with a couple of source folders and one destination path.

What happens is that the path actually changes from time to time. I think after about the 2:nd or 3:rd time I run the backup CBU file it changes the destination path to root drive folder.

If it is of any help, here is the cbu file in text

 /backup_operation /type filesandfolders /source "Z:\folder|Z:\anotherfolder|Z:\yafolder|Z:\lastfolder" /simplecopy /compressionlevel low /destinationtype  destinationtypediskfile  /destinationpath "F:\myDestination\" /backup_type incremental /parent_incremental_snapshot_no -1 /parent_backup_storage_type  destinationtypediskfile  /parent_backup_path "" /diskusage normal /processorusage normal /log_file "F:\myLogfile.log" /log_method "create"

As you can see, Z: is the local source harddrive and the destination is on F: drive which is the exernal drive.

What happes in the first couple successful backups is that it appends “DRIVE_Z” into the destination folder path like F:\myDestination\DRIVE_Z\ and does not save in F:\myDestination, example:

That is ok, I can live with that appended “DRIVE_Z” folder structure, not pretty though :slight_smile:

But it is not ok when, after the 3:rd backup or so it saves in F:\ root instead! Example:


Now I have F:\myDestination\DRIVE_Z\ and F:\ as destination paths, double the space is taken as of result of it and I don’t know which files are current or not.

All I ever do is that I run the same cbu file and the external drive is always referenced as F:, no error messages at all only “Success” messages.

This bug must be solved! This bug that I call Mr Haphazard destination :slight_smile:

Thank you for reading


Please make sure you use the latest version.
You can download it here


I thought I had the latest (updated recently). Will have a go with it, thanks for the reply