CB -> unable to access mounted backup -> file system not reconized

Hi there

I have created a full backup of my system using the “System Backup” button in the home section 5 days ago.
The backup has been successfully stored on my USB3 external HDD.

Now i am trying to mount this image which is successfully mounted and also has a drive letter assigned (in my case i chose letter F:).

The problem now is: when i try to access this “removable device F:”, windows tells me that the file system is unknown and the drive needs to be formatted.

  • I tried mounting the image read-only as well as with read/write option.
  • I tried several different drive letters.
  • I restarted my notebook and tried again.

I am using:

  • Surface Book with Windows 10
  • Comodo Backup
  • The drive C: is NTFS, bitlocker encrypted
  • I did not set a password for the backup
  • I am using Administrator priviledges.
  • The image file is around 237Gb of size.

What can i do to access this mounted backup file?

Any help is highly appreciated, since i urgently need a file which i accidentally have deleted.

many thanks