cavwp.exe crash and then system hang up


O.S : windows 10 x64 pro

I get the following error shortly after logging in windows 10 after start or restart and then several times during the day.
It makes applications launches impossible for several minutes ; the computer doesn’t freeze but gets highly unresponsive.
I use the AV in statefull mode.

Faulting application name: cavwp.exe, version:, time stamp: 0x5da874ac
Faulting module name: Framework.dll, version:, time stamp: 0x5d9caed5
Exception code: 0xc0000005
Fault offset: 0x0000000000008c32
Faulting process id: 0xb54
Faulting application start time: 0x01d5fc6d5b7071a7
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cavwp.exe
Faulting module path: C:\Program Files\COMODO\COMODO Internet Security\Framework.dll
Report Id: 07954f67-fc1c-43ae-8227-ac47d155c21d
Faulting package full name:
Faulting package-relative application ID:

How can i solve the issue ?

Wait for stable version to be released soon that fixes this issue.

hi guys

exact same problem as yours
I tuned the darn process: low priority + affinity set to 2 cores on 6 (Bitsum Process Lasso comes handy for this)
puter working fine since (fingers crossed)
I hope it helps

we shall be waiting for that “stable update that should fix this known issue” ;D


I downloaded and installed the RC version and it works like a charm.

Unfortunately, cavp.exe just crashed with the RC version.

How to get notified when the stable version is released ?

Hello GritNatZ,

Thank you for reporting.Did you got any crash dump on your CIS folder? If you got kindly send me via PM.
Have a nice day!

Thanks in advance,

Though it crashed 1 time, it has been stable so far.

Hello GritNatZ,

Thank you for your response.Could you please send me your crashdump?
Thanks in advance.

Kind Regards,

Hello GritNatZ,

Thank you for providing the requested dump and I have forwarded your crash-dump to my developing team members for further investigations.
Have a nice day!

Kind Regards,

Hello Dharshu,

You’re very welcome.

Have a nice day too !



Can you reproduce the problem & if so how reliably?:
No it happens randomly

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
CIS crashs randomly, It freezes my PC, I must hard reset my computer to solve this issue.

One or two sentences explaining what actually happened:
CIS crashs, but still running in task bar, it freezes my PC.

One or two sentences explaining what you expected to happen:
Not to crash randomly

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
I used “Comodo unistaller tool” to remove CIS and I clean install CIS but it still crashs with the same error.

Exact CIS version & configuration:
CIS Version :
CIS Configuration : Comodo internet security : Active - attached

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Modules enabled : AV (Dynamique) + Firewall (Personnalisé)

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
OS Version : Windows 10 64 Bits Version 1909 (18363.752)
UAC Settings : “Ne jamais m’avertir”
Account type : Administrator, local account

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=MalwareBytes Free

Attached File:
KillSwitch : I can’t install it, screenshot : KillSwitch_error.jpg

Here is the Event tracing error :

Nom de l’application défaillante cavwp.exe, version :, horodatage : 0x5da874ac
Nom du module défaillant : Framework.dll, version :, horodatage : 0x5d9caed5
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000008c32
ID du processus défaillant : 0x664
Heure de début de l’application défaillante : 0x01d60b1fc90ada49
Chemin d’accès de l’application défaillante : C:\Program Files\COMODO\COMODO Internet Security\cavwp.exe
Chemin d’accès du module défaillant: C:\Program Files\COMODO\COMODO Internet Security\Framework.dll
ID de rapport : b395af56-4722-424e-af92-f20cc15b2149
Nom complet du package défaillant :
ID de l’application relative au package défaillant :

Thank you for your help. :slight_smile:

I followed this thread :
and just installed the previous build “” of CIS. So far so good. Awaiting patch for the next release.

same issue… with multiple computer on W10 x64

Hello edouardo & domspiegel,

Thank you for reporting.These are the known issue in v12.1.0.6914 it’s fixed in the latest Beta/RC versions and it will be reflected in the upcoming stable release.After that will notify you.
Have a nice day.

Kind Regards,

Hello GritNatZ & edouardo & domspiegel,

We pleased to inform you that new version of CIS has been released.So could you please check with this version v12.2.2.7036 and update me.
Have a nice day!

Kind Regards,

Hello Dharshu,

v12.2.2.7036 seems to work just fine. Thanks for the information.

Have a nice day :slight_smile:

Hello GritNatZ,

Sounds good.Thank you for your response.
Have a nice day!

Kind Regards,


After installing v12.2.2.7036, i decided to use the proactive configuration file instead of my old custom one.
I added a rule to manage svchost.exe to prevent windows to update.

It seemed to be running fine until 2 days ago when i started getting cavwp.exe crashes again.

Then today after a CIS update, i couldn’t connect to the internet with FireFox or Chrome. I could still fping google ip and server name and Tor could also connect to internet.

I uninstalled all CIS components and reinstalled to no avail.

I reloaded my old config, could connect to the internet with no issue and almost immediately got a cavwp.exe crash

Should i create a new topic regarding the connection issue with the proactive config after today’s CIS update ?

Kind regards,


Hello GritNatZ,

Thank you for reporting again.We will check this and did you find any dumps in your CIS folder?If it contains in the sense,Please share me via PM.
Have a nice day!

Kind Regards,

Hello Dharshu,

I sent you an IM with the requested information, but I’m not sure if you received it as I can’t see it in my sent messages.

Have a nice day !

Kind regards,


Hello GritNatZ,

Thank you for your response.I got your dumps and shared to my CIS dev team for further analysis of the issue.
Have a nice day!

Kind Regards,