CAVS and Shell Integration (context menu)

CAVS appears to have made itself the default application for all file types on my system, i.e. when I double click on a file (eg a .DOCX file) the virus scanner kicks in rather than the application that opens the document (eg WordView).

In FolderOptions->FileTypes->DOCX->Advanced->Open Action is set as the default and the Application is WordView.

If I right click on the .docx file, its the “Scan with Comodo AntiVirus” option is bold, rather than Open

Note this appears to be true for ALL file types, the reason I have used DOCX as the example is that I tried removing DOC from the CAVS->Settings->OnDemandScan->General->SelectiveExtension to no avail, DOCX does not appear in that list.

Basically what I’d like is for the context menu item be there, but that it not be the default option - unless so designated via FolderOption->FileTypes>…->Advanced settings. How can I make this so.

TIA Phil Daneils

I am a very new user of Comodo Anti Virus and am having the same problem; if I double click an image file hoping to open the file in the default viewer I get Comodo Anitvirus offering a scan. I can’t find and setting that changes this behavioue.

This is very annoying; almost enough to stop using what appears to be an otherwise very good program.

Any help would be gratefully appreciated.


It’s always good to know that one is not alone

Peter there’s a utility call MMM+ Free that should allow you to to relegate Comodo Anti Virus to a secondary menu which should prevent it executing when you double click on things, you can pick it up here

It’s not the one I use, whiich is called ShellToys, but it is not free (there’s a 45 day trial tho’, so if MMM+ Free doesn’t do the trick then ShellToys will

I have actually posted this as a Defect Ticket - maybe if you do the same it will get it escalated up the list of things to fix.

Urbane (not a relative of Keith Urbane?),

Thanks for the tip and the link. MMM+ looks like a very useful little utility even without this problem.

Peter (:CLP)

Just RIGHT CLICK the file then click on >>> “Open With” >>> “Choose Program” this will then bring up a popup window. From there select the program and then tick the box at the bottom “Always use this…”



Thanks for the reply and I don’t wish to sound ungrateful - but that is NOT a suitable reply. CAV has taken away a major bit of Windows functionality (i.e. double-click on a file and open it with its default application). You might as well have suggested that I open the application and then use “File->Open” to find and open the file I need.

You have to wonder at how much testing this product had before it was released! Comodo NEEDS to fix this bug otherwise why would anyone bother with CAV. I’m sure AGV and other competitors don’t do this.

Peter :-TD

Bizzaro - I just wanted to prove to myself that it was still happening - so I bought Comodo Anti Virus out of hiding and the problem no longer manifests - even though the Comodo Anti Virus is bold.

I’ll have to see what happens when I reboot - can’t to that now in middle of backing up 80G.

I’m wondering if I should reinstall Alvira until they get Comodo AV 3 finished.

I also wonder if CAVS keeps a fingerprint d/b of files its scanned (date/time stamp, MD5 & CR checksums etc) and if the file’s fingerprint is unchanged then the on demand scan does not happen.


CAVS 2 has been in beta and we haven’t seen much improvement with it for a number of months. We are due to see CAVS 3 come out by the end of June both as part of Comodo Internet Security and a stand-alone product.

Most of us Mods don’t directly work for Comodo, moreover just helpful comodo users who have been around for a number of years and or have been extremely helpful to others.

I suggest using something like Avast for now until a stable release of CAVS3 comes out.



With all due respect, pja, this version was never officially “released”. It was, and still is, classed as beta. As with all beta software, it can, and sometimes does, cause problems and, as such, should only be used in a production environment if you are aware of and are willing to accept the possible consequences.

Comodo NEEDS to fix this bug otherwise why would anyone bother with CAV. I'm sure AGV and other competitors don't do this.

Unfortunately, I’m almost certain this bug will not be fixed in V2. Development on Beta version 2 has ceased as the development team is working towards a June release of CAVS3 BETA. CAVS3 BETA will utilise a totally different architecture. If you have V3 of Comodo’s firewall installed, the scanner that is built in is an early version of the scanning engine that will power CAVS3.

Given that yourself and Urbane.Tiger are two of the only three people that this has affected (and Urbane.Tiger now reports that he cannot reproduce the error), this may, unfortunately, be just “one of those things”. I realise that this is a cold cup of comfort, but hopefully the fixes suggested by Urbane.Tiger (Mmm and TweakToys) will do the job for you.

Ewen :slight_smile:

edit : The items in bold red were added after originally being omitted from the post. Unfortunately these two small omissions totally changed the intent of my post. Sincerest apologies.

g’Day Folks

Well I finished my 80G backup and rebooted, and I cant repeat the problem.

Can anyone confirm whether CAVS fingerprints scanned objects as I previously suggested. Both pja and I are newcomers to the CAVS 2 product, and there seems to be a learning “paradigm” in the firewall and elsewhere.

I understand that CAVS 2 is “on life support” pending the release of CAVS 3. Ewen (“panic”) maintains that CAVS 3 is a totally different architecture to CAVS 2, that maybe so, but that would not prevent the reuse of code - I’m sure MS would claim that Office 2007 is a totally different architecture, but there’s an awful lot of code from Office 2003 in the new version.

One of the features of CAVS 2 I like (I’ll change that to love) is HIPS. I feel a lot safer having HIPS and Defense Plus popping up and asking me if I really know what I’m doing, although I suspect that some folks would find it annoying - just as I find Vista’s UAC annoying.

I hope that HIPS or a functional equivalent will find it’s way into CAVS3, it would be sad to see it go.

Back to the original issue - it seems to have gone. I have a fairly “big” system with 700,000+ NTFS objects containing about 6.5M discrete (scan-able)objects, either as native streams or compressed streams in zips, tars and isos.

It seems to me that CAVS and the Firewall are changing their behaviour over time. Initially I was not aware that CAVS scanned outgoing mail, now it a systray message slides up telling me it’s doing so, it did not tell me of updates, now it does. Similarly the firewall has started to tell me of things it learns about software when I run it, mainly the COM services being used. I can assure you that I have not knowingly changed any settings.

I decided to leave CAVS 2 running as my primary av shield, but I’ll continue to do nightly scans with Alvira & Kapersky.

BTW - Its ShellToys not TweakToys - the latter could be an alternative name for X-Setup Pro, which I call Souper Tweaker, its another very useful gadget - like ShellToys it’s also payware.

I doubt that I can add much more to this thread - thanks for all you input and comments

c’Ya TUT