CAVS 1.1 Uninstall - Finally!

For everyone who has fought with uninstalling CAVS 1.1, I am writing this to let you know what I did to successfully uninstall it, after months of having this annoying MSI popup constantly flashing on the screen. Up to this point, I have run all the batch files provided by Comodo, run LSPFix, SafeMSI, the Windows Installer Cleanup Utility, I’ve cleaned the registry by hand (regedit), and all manner of registry utilities, to remove all instances of Comodo Antivirus. I got rid of CAVS, but still have had the annoying popup from MSI. Everything’s here,887.0.html, starting on about page 5, through page 9 (there might be a couple other spots in the forums, like the Beta Corner, but this is the majority of it). Edit: Here’s the encapsulated version of all my adventures into the uninstallation of CAVS 1.1 —>,3931.msg30754.html#msg30754.

In between versions of CAVS 2.x Beta, I did the following:

Downloaded CAVS 1.1 from the Comodo website again.

Ran ZSoft Uninstaller, to Analyze the drive prior to installation.

Ran CAVS 1.1 Setup.exe file.


Ran ZSoft Uninstaller, finished Analyzing the drive, post-installation.

(this was so I could see what happened, if need be)

Closed ZSoft.

Ran ServiWin. Disabled (start type) of the CAVasm driver, and Comodo Antivirus & Antispyware service.

Opened msconfig. Unchecked CMain and CLPTray, apply, ok.


Ran ZSoft Uninstaller. Selected Comodo Antivirus, Uninstall.

Followed the prompts, Rebooted.

C:\Program Files\Comodo, deleted folder for LaunchPad (which was empty anyway).

CAVS 1.1 is gone.

The annoying MSI popup is gone.

Hope this helps anyone and everyone who needs to uninstall CAVS 1.1 and has difficulties with uninstalling it.


NOTE: I had reinstalled CAVS 1.1 previously, but it was with the original install package. My thought was that the installer, once used, was corrupted, thus I downloaded a new one. Comodo, even after the final release of CAVS 2.x, you might keep CAVS 1.1 available for download, just for this purpose…


You ain’t kiddin’!

Zsoft Uninstaller is a great piece of software,for which I’ll take full credit for recommending on the forums lol :■■■■

Thanks a lot to Little Mac and andyman35 (and everyone else who has tried to solve this problem) - this should make a lot of people happy. Just tried the same procedure and it works a treat!


Great, anderow, I’m glad it worked for you!

BTW, I just added an Edit note to the Topic Post here.


Hey Little Mac,
I really apreciate the note. I will give the solution a try (I didn’t format, hope this works)
A nice holiday gift!
Have a Happy New Year,

Dr Pete

Little Mac,

 I tried your method as written and I don't see the pop-up as of yet.  I did have this message in the Comodo/Antivirus install log "Comodo AntiVirus LSP Uninstalled Successfully."  Is it safe to delete the Comodo Antivirus floder?  There seems to be some junk left over in it.  Anyways, thanks for your solution.  So far so good.  Will update if anything changes.  :BNC

Good, I’m glad the LSP uninstalled successfully; that’s part of the reason to stop the services before uninstalling the application, as it seems that sometimes the LSP doesn’t go away as it should.

As far as removing the CAVS folder, that should be fine. You’ve done the uninstall routine, the program itself should be gone, so no problem.

If you get an error message while trying to delete/remove the folder, that’s another issue to discuss (as that could mean there’s still something running…).

So give it a shot and see what happens.


Do I need to go through all this ghastly looking uninstal procedure to solve my problem?
Using BTinternet broadband and Outook it seems that Comodo AV is stopping emails going out (even if I turn “scan outgoing emails” off). Everytime I use outlook it asks to confirm my network password, I put it in and tick the box to save it, then two seconds later the same pop up comes back. Again and again. I cannot seem to stop it happening. BT cannot help as they say it is a CAVS problem. This problem does not occur on my other computer which does not have CAVS.

Any clues before I take the ultimate step and reformat my hard drive which seems to be the only sure way of removing CAVS Beta 1 and hopefully solving the problem for good.


You shouldn’t have to go through the “ghastly looking uninstal procedure” to get rid of CAVS 1.1. That’s only if you have problems getting the uninstall to work properly. Numerous users had problems with the Installshield routine that Comodo used with CAVS 1.1 (which is why they developed their own for all further versions). That said, here are steps to take to help with the uninstall (still no guarantee, but they should help - and keep in mind, not ALL users had problems with uninstalling 1.1).

Download and install Serviwin; it is free and available here: ServiWin: Windows Services/Drivers Tool (start/stop/restart service) This will help with services & drivers.

Follow these with no other applications running, and disconnected from the internet (Exit/Turn off all active security applications, such as firewall, etc). Do this at each step.

  1. Go to Start/Run, type “msconfig” (no quotes). Go to the Startup tab, and uncheck the boxes for CLPTray & CMain. Apply, Cose, but don’t reboot.
  2. Open Serviwin, and click on the left-most gears icon at the top, to access the Drivers. Find the entry for CAVasm and Disable it (from Startup).
  3. While in Drivers, look for a CAVS LSP entry; there may or may not be one. If there is, Disable it from Startup as well.
  4. Click the next gears icon, to open Services. Find the entry for Comodo Antivirus & Antispyware Service and Disable it from Startup. Then close Serviwin.
  5. Reboot, and disable all active security software.
  6. Run the Uninstall for CAVS 1.1.

I know there are several steps there, but it should help by making sure that CAVS is not running (at any level) when you start the uninstall process.


I have gone thru all the procedures but the problem that I am having is that when I try to install 2.x, I get get a message saying that Comodo Antivirus is already installed. Please uninstall first. I really need help with this. There’s no evidence of ao any remaining files after uninstall.

I FINALLY got CAV 1.1 uninstalled. Used the program UninstallCAV1.1 which I downloaded from one of the forums. I have to say that I was SHOCKED that it worked after all the time that I spent trying to get rid of CAV1.1 from my main machine. I’ve read so many post on this subject That it isn’t funny. :SMLR

Used the same program on my 2nd machine with varying results. Was getting the same message as from my previous post. Ran a search on My C: drive to find any files that were left. Deleted those files and ran CAV2.4…No problem. Both computers seem to be running well with the new 3.0 Comodo Firewall.

I have one more computer to go. Hopefully I will have the same success. I have to believe that this program does not work the same for all computers. Why, I don’t know. But I am estatic that I am just about done with this.

The guy who developed this program, got it right!

Thanks (B)

Glad it’s working for you, Coreroom! Yes, each computer will likely respond differently, as they all have their own little peculiarities. Sometimes it works great; sometimes it doesn’t.


PS: Welcome to the forums!

I finished removing CAV1.1 from my 3rd machine. I found that you can use CCleaner (free) to do the uninstall (There is a uninstall for CAV1.1 in the program’s tools). You close all The CAV processes before you do this. When it is completed there will be a few files left in the directory which you can manually delete.

I thought I had gotten everything until I tried to load CAV2.0. I received a message that CAV1.1 was still installed. I finally found out by using jv16 power tools and opening the software manager that remnants of CAV1.1 was still there. It was in the Program Files\Common Files\InstallShield directory. Jv16 will delete this InstallShield file. I did a search after that typing in cav and removing any remaining files. I also did a search with comodo and deleted any directories that corresponded to CAV1.1. I installed Cav2.0. After that the rest is history.

I hope this helps with anyone still trying to uninstall CAV1.1.

Yep, I think it’s typically these installshield remnants that cause the problems. It’s what caused mine to continue to try to reinstall it all the time. CAVS 2 could install, but then 1.1 kept trying to reinstall (the installshield routine kept popping).

Thanks for posting your details; hopefully no one else is still running 1.1, but I’m sure there are probably some… Here’s hoping your suggestions will help in that scenario!


Don’t want people to spend the time like I had to…

Know to bigger and better things…CAV 2.0 & CFP 3.0

Thanks to the forums

I’m having a problem uninstalling or re-installing CAV2.
If I try to install I get a message saying It’s already installed.
I no longer have it showing in Add/Remove programs.
I don’t have the install folder any more.
If I install Zsoft, I get a message saying “Uninstaller.exe is not a valid Win32 application”
I must still have something hogging my computer as ALL my antivirus/trojan/spyware software has stopped working and gives a similar message.
Is there a registery entry that tells the new install that an old install has been there, so I can delete it and re-install.

Any other Ideas as to what is stopping all my security software would be helpfull.
The other problem is that I can’t boot up in safe mode. The option comes up, it starts to try and then reboots it’s self.


I know it’s several pages of thread to read through, but this link is to the primary thread regarding uninstallation issues. It was written to deal with CAVS 1.1 (yeah, the same one I had issues with), but some aspects (registry entries and whatnot) will still be relevant.

Your mention of the computer rebooting when you try to enter SafeMode is a bit concerning, though. I take you can boot normally, but just not into SafeMode?


With CAV 3 just around the corner, I believe it is safe enough to now close this thread. :P0l