CAVL v1.1.268025.1 Success on Linux Mint 12 :-)


Firstly I want to say Thank you very much Comodo for making an anti-virus program that is highly polished and works! I have waited a long time for a linux GUI anti-virus solution which offers popup notifications, scheduling, mail integration, automatic updates, and an easy to use, intuitive gui. Excellent work, truly. :slight_smile:

I run LM12, Kernel Linux 3.2.0-17-generic-pae, Gnome 3.2.1, with a Cinnamon desktop on an Acer Aspire 6930g, so I was a little disappointed at first when it appeared it wasn’t compatible with my version, however I was so impressed with what it offered I thought I would try and install it and see what happened.

I started with version 1.0, but the installation threw up problems with freezing my computer, and after doing many searches on the internet to find solutions and getting nowhere I had to remove it. However as the 1.1 version also stated support for Linux Mint, I thought I’d try that too.

First installation of 1.1 froze my computer to the point I couldn’t even login from a terminal, but I persevered and got success.

To install this successfully, what I had to do was hold down shift during boot to get to the grub recovery options, then drop into a root shell. I had previously moved the install package from my home account to my root home account, so then I installed it using ‘dpkg -i ’.

Next I ran (still under root from the grub menu) ‘bash /opt/COMODO/’ .
This completed without errors, so then I exited and rebooted (when I had originally tried installing from the desktop using sudo bash, it came up with errors).

This time I was able to login to my desktop, and the Comodo icon appeared in my system tray, however it seemed to be trying to automatically update the database (I could tell by the download activity in my system monitor), but the notification still said it had never been updated, so I clicked to update manually, which then told me it was up to date even though the main interface said never. So I thought a restart was in order.

I restarted only to be locked out again, so I rebooted holding the shift key to access grub, and once in the root shell, I re-ran ‘bash /opt/COMODO/’, which again threw up 0 errors, and then rebooted.

This time I was able to login and found that Comodo was reporting All systems active and running, and the database was showing it had been updated, and suggested a first time scan which took an hour (would have been shorter if I had thought to exclude my /var/spool/havp/ folder as it took a while to read those files), however no hangs and 23 viruses detected (clamav testfiles, clamav quarantined, and some windows viruses).

I then setup the mail scanning section, but the mail scanner just said restarting and did nothing more. I got around this by ending one process with ‘sudo /etc/init.d/cmdavd stop’ in a terminal, then killing cmgdaemon with ‘sudo kill ’, then ‘sudo /etc/init.d/cmdavd start’.

When I re-accessed the Comodo main screen it detected a problem and fixed it by restarting cmgdaemon itself (no restart necessary).

Now every time I shutdown and restart, everything is working as it should, even the automatic updates.

I hope this info proves useful to others, and maybe proves useful to Comodo in identifying why a standard install procedure from the desktop failed.

So here’s what I recommend if you run LM12/Ubuntu Oneiric ;-

  1. download v1.1.268025.1 (Debian/Ubuntu/Mint version) and move it to your root home folder.

  2. Reboot and hold down shift key until the grub menu appears and select the recovery option.

  3. drop into the root shell (with or without networking) and logon as root. (I found that I had to run the file checker 1st in order to be dropped into a proper root shell (don’t know why) but just dropping into the root shell as a first option caused dpkg to not work properly.

  4. Run ‘dpkg -i ’

  5. Then run ‘bash /opt/COMODO/’ and restart.

  6. When you login it might be a bit slow at this time, but I think this is because the database is updating automatically. Check to see if it reports it is up to date (like mine it might report ‘never’ on the main screen, but up to date on the manual update button.

  7. Restart holding the shift button, and then follow steps 3. & 5. and reboot.

  8. If you have the same issues I did with setting up the mail section (though I think maybe not), do what I did to restart the services.

If you have further questions, or a better method (or no issues with a standard install proceedure, I have set reply notification on.

My apologies in advance for this long post, but I thought it might be helpful if you knew exactly what I did and experienced before summarising into steps.

Thank you again Comodo for understanding that some of us want a polished, easy to use gui, with all the features that one might expect to see only on Windows (like a popup notification of a found virus rather than having pour through countless system logs). I don’t want to help spread viruses, even if most are windows based.

[attachment deleted by admin]