CAVL on access scanner not working on openSuse 12.1


I’m new on this forum and please excuse me if I ask a question which was asked before.

I’m using openSuse 12.1, kernel “Linux 3.1.10-1.16-desktop x86_64” and KDE "4.7.2 (4.7.2) “release 5” " and after I installed CAVL v. 1.0 I noticed that the on access scanner does not work.
I ran the CAVL diagnostic and I followed the instructions, the on access scanner started but after I restarted the computer the scanner stopped again. I have repeated the actions I described above and I had the same result. The modules “redirfs.ko” and “avflt.ko” seem to be installed but they don’t seem to work with my current kernel version.

I attached some screen shots which may be helpful.

Can anybody help me? Thank you.

[attachment deleted by admin]

i’m have same problem, is seemly by shell (sh shell) load comodo startup script

i’m using opensuse 11.4x64, gnome desktop

when the comodo agent not running if you running /opt/COMODO/ start to start agent, the out put is commodo agent was running

if you running bash /opt/COMODO/ start to start agent, agent will start ok.

i correct this by: open control center > Startup Application, in [tab startup program] choice: Comodo Antivirus choice edit in command change:
/bin/sh /opt/COMODO/ login
to /bin/bash /opt/COMODO/ login

this will affect current user, if you want do it for root or other user you must chage startup of user you want

[attachment deleted by admin]

Thank you for your answer. I will check this as soon as I have some time. :slight_smile:

sorry adi79, i has test it more it seemly ok with root account, but problem with other, i think it get problem with permission of user when it run, …
i’ll try to find reason… :-

after times try to fix now it work ,

  1. :
    change first line of 3 file : /opt/COMODO/, /opt/COMODO/, /bin/bash /opt/COMODO/ form : #!/bin/sh to #!/bin/bash
  2. :
    add too line

bash /opt/COMODO/ start
bash /opt/COMODO/ start

to file : /etc/init.d/boot.local

reboot ad see result
hope you test give me feedback, :-\

Hello thangbom8008,
I tried your solution and it works. But on KDE it looks a little different:

- the path to "/bin/bash /opt/COMODO/ login" is added through the Configure Desktop panel the option Startup and Shutdown as depected in the attached screenshots;

- I added these 2 commands: 

bash /opt/COMODO/ start
bash /opt/COMODO/ start

in the file “/etc/init.d/boot.local”;

- I started CAVL and when prompted for error I followed the steps;
- and in the end I made a reboot. 

I installed CAVL 1.0 on openSUSE 12.2 (x86_64) this time. And on openSuse 12.1 it would have worked in the same way.

[attachment deleted by admin]

And on the other hand “/bin/bash /opt/COMODO/ login” is no longer necessary to be specified. I just edited the file “/etc/init.d/boot.local” with the two commands and this was enough to make CAVL start. :slight_smile:

CAVL 1.0 works as I said before but there is a problem. On my openSuse system with this configuration:

OS: Linux 3.4.11-2.16-desktop x86_64
System: openSUSE 12.2 (x86_64)
KDE: 4.8.5 (4.8.5) “release 2”

It slows my computer very much. Anything is slower. So I uninstalled it and I noticed that without it everything turned back to normal.
In conclusion I don’t think that I need an on access scanner on openSuse at this time anyway. But that it does not mean that I may not reconsider this in the future. ;D

To those who want to try it further I wish them success.

in the first time when install a have same problem about CPU consume with CAVL, it make my PC very slow, and on-access working not good as expect (it seemly working like application instead of service or [layer above OS and below App] or integrate with OS, i thinks it should like that)




After test few time i decide uninstall it.

CAVL is good news for linux user, but it must improve to much to make it is a good choice for linux user.