CAV Version 2 Not Updating?

I can’t get CAV Version 2 to update. Did an unistall, registry restore, reinstall, and that did not help. Anyone else having this problem? Win 2K SP4 Rollup 1.

Do you use a limited account?


No, I never create accounts with limited permissions.

Hi Guys,

I installed Comodo a week ago, and today have realised that it is not updating, it often trys to and i see the status tray icon flash on and off but it fails to update. Today ive checked and it last updated on the 4th April.

So i tried to do a manual update and it goes through the status of downloading or showing the blue bar of 16 updates and then at the end says;

“Error. Unable to complete the virus definition database update, please try again later”

I am not using any form of proxy, just a straight connnection to the internet

Any ideas??


Hi zenos

Sorry no one responded to you before now. I just had an automatic update about 5 minutes ago and all worked well. If you still cannot update you possibly have a corrupted update file and may need to reinstall. If it is working now for you it could have been a server problem. Let us know and we can help you out.


Hi dw2108

Are you still having trouble with the update on CAVS? If so you may need to reinstall the program. It is updating fine for me.