CAV recognized by Microsoft

I’m new to the Comodo products. I noticed that Microsoft security center does not recognize CAV as a virus protection program. I have checked the “I will monitor the a/v program myself” but am concerned about the protection center center not recognizing the a/v program, especially since it does recognize the firewall. Any advise would help (maybe I have not congigured it correctly).

Hi Budzoid,

Have a look at these two posts:
Similar question:,4186.msg31538.html#msg31538

Possible answer:,4186.msg31540.html#msg31540

Integration may yet be coming.


Unfortunately, it’s a MS issue… So them writing the code to include CAVS could take a while… :cry:

Doesn’t change anything about CAVS’ (or CPF’s) effectiveness, tho’, just 'cause MS doesn’t acknowledge the software. I promise not to rant about it, but I myself don’t rely on MS to tell me anything about security, and I really feel that WSC is a waste of resources, especially if you’re not relying on the XP firewall… :wink:


Here is a Microsoft link to visit if you wish to read more on its own Windows Security Center feature: Managing the State of Security.

And here is an excerpt from the above linked article: “Recently, several publications have questioned whether WMI is a secure data source for reporting on a system’s state of security. These articles claim that a user may be misled through spoofing or tampering with the WMI data consumed by Windows Security Center for reporting purposes. However, a cursory review shows that the use of WMI does not introduce any additional security risks. In fact, if an attacker has access to the WMI repository, the system has already been compromised.”

[WMI = Windows Management Instrumentation (WMI) database]


Thanks for the info. I have turned off MS A/V monitoring. I have just stumbled upon another problem. I hope this forum is the right place for this. I am an Earthlink user. When I check my e-mail, it is slow, but no noticeable problems. I just downloaded Thunderbird and rec’d two e-mails from you. When I try to send a test message to myself, it shows the A/V scan for the outgoing mail. then I receive a message that there was a problem sending and do not receive my message(?). I then uninstalled T-bird and went back to Earthlink mailbox. The strange thing is when I try to send a test message to myself, it sends it but does not show the A/V scanner for the outgoing mail. I then reveive the test with no problems. To sum it up, the outgoing scanner shows up with T-bird but I don’t receive the message. With Earthlink mailbox, I receive the test e-mail but it does not show the outgoing scanner.
Any ideas why?

When you’re using Earthlink, you’re checking your email online, right, rather than thru a client program (like TBird, Outlook Express, etc)? If it’s an online access, that’s why the email scanner doesn’t do anything; you’re operating thru your browser, and CAVS’ email scanner doesn’t apply.

As to the TBird issue, what program gave you the error message, and what was the content of the message?

Does Earthlink provide your physical internet connection? Did you set up the SMTP settings for your outgoing mail in TBird?


Yes, I used Earthlinks mailbox prog. When I installed T-bird (which I prefer) the message comes from Earthlink saying the SMTP is not configured and can not access it. Before I had to do a complete sys. recovery and stat fresh, I was using T-bird with no problems (?). I really want to use CAV but i simply cannot. I uninstalled CAV and re-installed AVIRA and will try to install T-bird and if all goes o.k. I will then delete Avira and try to re-install CAV. Note: Before the sys. recovery, T-bird installed flawlessly. Maybe I have gremlins in my machine:) I will keep you posted on my progress.

Hmm, sounds like TBird didn’t have the SMTP settings all the way through…
When you set up for Earthlink, using Earthlink’s interface, it’s probably all automatically there…
But with TBird, you have to set everything up yourself. It might import basic settings, such as email address, perhaps the POP for retrieval and the SMTP for sending, but it’s not going to have passwords, etc. Your SMTP probably requires a password as well as the POP, and you have to specify a “default” SMTP server for each mail account in TBird (if you have more than one).

When I switched from Outlook Express to TBird, I thought it was somewhat complex, comparatively. But I haven’t had any problems using that and CAVS thus far.

Post back your results from the Avira Antivir test. We should be able to get this figured out and resolved…


PS: I believe the Earthlink mailbox program is actually not resident - it’s web-access; thus CAVS email scanner doesn’t scan it… Here’s a test for you, if you want - disconnect your DSL, or deactivate your network connector. Then try to open the Earthlink mailbox program; see what it says. I’m betting it’ll give you an error message…

Hi Little Mac. I’m wondering if I have Gremlins in my machine. I uninstalled Avira A/V and then re-installed CAV. I must have done something right because I now can send test e-mails to myself and receive it. Also, I am now receiving all other e-mails from other people. I guess I configured T-bird right this time. But now I noticed that when I send an e-mail, I don’t see the outgoing scanner in the right hand corner that I was seeing before(?). What may I have done wrong this time? The CAV is set to scan both out and inbound mail. Is there a setting I missed? It seems wierd that when I could not send myself test mail, the outbound scanner showed up. Now that I can send and receive mail with T-bird, It does not show the outbound scanner. If I could fix these little bugs I’ll be a COMODO man for life. Any suggestions?
P.S. I want to thank you for all your time and help you are giving me!!! It is greatly appreciated.

Oh boy, aren’t computers fun! ;D

Well, I’m glad CAVS and your email are working now with TBird.

No outbound scanner in lower right corner… I presume you’re referring to the little popup box, that raises and lowers from your taskbar?

Basing it on that presumption, here’s what I experienced with CAVS & TBird…

When I set up CAVS, I chose to scan incoming & outgoing email, to show the animated icon for both, and to certify both. I immediately noticed the animated icon (a little envelope thing with an arrow or something) in the systray. I also noticed the certification text in the email at the bottom, and a 1KB attachment containing the certification as well. I never saw the little slider/popup scan progress thing.

I didn’t like the 1KB attachment being there; I want only the certification in the email itself, so I took the certification off; I figured if it found something while scanning, it would let me know. As soon as I did that, I got the little slider/popup about outbound scanning. Weird, huh?

Based on what I’ve read, some people get the attachment certification, some people get the in-text certification. I’ve not read anything about different icons or notifications. If you have the certificaiton on, and can see that the outbound emails in your Sent box are certified, you know they’re being scanned. Apparently it can be a little glitchy, so that’s probably nothing to worry about.

As I’m helping with the Beta testing, I’m making sure to document my experiences for Comodo so they know areas to look at for improvements. They are, I’m sure, concentrating on areas of “high” importance first - resource usage, major software interaction issues, etc. They have shown themselves very diligent to address user issues, though, and to continue to improve their product.

BTW, what version of CAVS do you have?


PS: No problem, I’m glad to help as I can. I’ve gotten a lot of help here, so I’m happy to pass that on.

Hi Little Mac. I read your post and thought I could configure my mail prog (T-bird). I was getting the little box with the arrows when I sent myself mail. I was hoping to get the scan box in the right hand corner that I was getting with Earthlink mailbox (even though I did not receive the test mail) Now that I can use Thunderbird with no problems, I don’t see the scanner anymore and now I get the Attachment saying the mail is clean. I tried the settings you suggested and now all is messed up. No more outgoing scan and my incoming mail has the attachment! I only want to see the outbound scanner and not get the attachment saying it is clean when I receive it. If I can’t resolve this, I’m going back to Earthlink mail and uninstall CAV and install AVAST! This is getting very frustating!! I thought installing T-bird would solve this problem, but nothing I do seems to work like I expected it to. Maybe the next version will fix this stuff and I will give it another try.
P.S. The firewall is the best I have used. I only wish the bugs can be worked out with CAV. :frowning:


Sorry you’re having such difficulties getting it configured the way you want it/need it.

Let’s walk thru this to see if we can’t get it fixed…

Open CAVS, go to the Settings tab.

Part 1: Click on Email, make sure you’re on the “General” settings.

Under “What to Scan” you want both boxes checked - incoming & outgoing.

Under “What to do When Scanning Email” you want both boxes checked - animated icon (incoming), progress indicator (outgoing).

Click “Apply.”

This should get you your popup box.

Part 2: Now go to the “Advanced” settings for the Email scanner.

Under “Certify Email with Signature” make sure neither box is checked - incoming & outgoing.

Click “Apply.”

This should remove the attachment (and also the text signature as well; at this point we don’t have the option to choose there, but it’s been added to the Wishlist).

At this point, for good measure, reboot your computer.

Now try it and see what you get…

Post back the results!


Hi again. I tried everything you suggested and nothing has changed. I’m just going to give up and go back to Avast A/V. I will check in from time to time for the next generation CAV and try again. Thanks for all the help! I will still use the Firewall because I think it is the best out there.

Sorry it just won’t work for you. It is a Beta; there are still bugs… :cry:

The email scanner does not appear to work at all with Outlook and a Microsoft Exchange server, so you’re not alone.

It does seem to be working okay for me, with TBird. I don’t like having the attachment signature, rather than just text, tho, but I don’t have an option to change it, other than no signature. Such is life; I’ve turned it in on the Wishlist anyway; hopefully that will change as well as the glitches getting worked out.


Little Mac, Thanks again for trying to help. I believe Earthlink may have some role in my problems. Anyhow, I have switched back to Avast along with T-bird and CF. All seems fine now. Is there some way to me put on some list that will notify me when CAV is out of beta and ready for full use (with the few bugs worked out)? I will DEFINITELY want to try again when it is ready. As I said before, the firewall ROCKS!!
Feel free to keep me updated on all the progress.

If you’re using CPF, there might be an announcement for the final CAVS release in the “News” section at the upper right of the main screen. I don’t know if they’d do that or not, but it seems like a final release of CAVS would be worthy of mention!

The best way would probably be to keep an eye on the CAVS forum. No doubt there will be some form of announcement there.

To make you aware, some users have experienced some sort of compatibility issue between CPF (or perhaps some part of ABA) when combined with Avast! HE (perhaps just with Webshield enabled). Symptoms seem to be extremely slow webpage retrieval, and/or html gibberish instead of the page. My understanding is that Avast! considers it to be a CPF issue, and that perhaps Comodo has a solution for the next CPF final release.

However, not all users have experienced this by any means. I even used Avast! HE for a little while w/CPF and did not.

If you don’t have the problem, then you’re good to go. If you do, know that it is known about. I know the Avast! forums discuss it, and there’s more than one thread here as well. The primary one is titled (I think) “Does anyone know what this is?” Egemen (Comodo Staff, CPF development) has been on there and acknowledged that they are looking into it. I have not seen it mentioned in the release notes for the current round of CPF Betas.

I’m glad to help; I wish it could’ve been resolved.


Hey again, since I switched back to Avast, I have not had any problems. I still think my ISP (Earthlink) might have something to do with my problems. As I reported in an earlier post , CAV found a part of Earthlink’s TotalAccess software (Fastlane) as a virus and was quarantined. No other A/V program I’ve used (Antivir, Avast, and Nod32) found this(?). I know from experience that some programs just don’t play well together. Example: If you use Zonealarm and try to download Avast, you get a warning message that not all of Avasts’ shields will work properly and you must turn off certain things. (I think ZA is just jealous of Avast’s program and wants it’s users to use thier A/V program). Anyhow, I WILL keep an eye out in the forums for the final release of CAV and try again. Thanks for all the feedback.

At least ZA’s being honest… ? :wink: Well, hopefully all will continue to be well with Avast! I guess CAVS didn’t play nice with Earthlink there! Mean CAVS; you should play nicely! I shall have to frown severely. |:{ (:TNG)

CAVS Beta has made some big improvements over Beta; I think they’re definitely getting closer. Not close enough to start posing a final release date, but they’re moving in that direction. Still some big issues to resolve for a final product.

Keep your eyes/keyboard open for it…


I’ve been a Comodo PF convert for months now. I installed CAV before installing CPF and found all the problems everyone else had so I decided to wait. Last week I installed the Beta and thought I was home free. Everything seemed to work fine until one day I tried firing up my mIRC client and found it had been quarantined. After trying to restore it from quarantine, everything went wrong… system slow down, system freezing, etc. Even after uninstalling it and reinstalling my previous AV (Free AVG), problems remained. I finally resorted to a System Restore. After 2 system restores, everything’s back to what it was before.

I still want to use CAV and have full Comodo security on my system. Any idea what might have caused the restore function to ■■■■■ the system? If you need more details, let me know what I can provide you.




I believe in the other thread where you posted a similar message, Melih has requested that you provide them information regarding the specific version info on your mIRC client, and even send them the file so that they can try it out and see where the conflict is coming from.

System Restore… well, I used to be a big fan of that; I’m not really any longer. I had some trouble after installing the first version of the CAVS 2.x Beta, and did a Restore. From that point on, Windows Installer keeps trying to reinstall a version of CAVS 1.x that no longer exists in any form on my system. I’ve done some digging, and have come to the conclusion that Restore is over-rated. I’ve noticed that sometimes it leaves programs intact, sometimes it takes them out but leaves files and registry entries behind. When you reinstall, the installer tells you the program already exists…

Plus, if you ever do get a malware infection, Restore may save it for you, and keep you infected no matter how hard you try to get rid of it… :cry: