CAV-linux_x64.deb : libssl version issue

Hi Comodo Developers Team

I have downloaded the Comoo AV .deb file for Linux Mint 18.1 64bit.
I went ahead with the usual dpkg -i command, but at some point, I got an error message, stating:

cav-linux depends on libssl0.9.8 (>= 0.9.8m-1); however:
  package libssl0.9.8 is not installed.

I checked via application installer, and I have libssl1.0.0 ready on my system, including ancillary modules/sub-packages. For safety, I installed libssl-dev too.

I took then another try with CAV installation, but I still get the same error message.

Can you please have a look at it? Many thanks!

Kind regards

That dependency an be installed but is outdated version of libssl and that requirement should be upgraded. My tests are here - Comodo Antivirus in Linux - - dependency could install but not real-time protection.

I have the same problem!

I am also experiencing this issue.

Same issue here - can’t install on Linux Mint 18.2 Beta (also tried with current 18.1, with same results regarding libssl version). Until CAVL gets updated, I’ll stick with Sophos free Linux AV, but I’d rather go with Comodo.

I’ve the same problem … Libssl0.9.8 out of date

Fix the bug pleaaaaaaaaaaaaaaaaaaaaase

Ubuntu version have the same problem, the package’s same ! :-TD

Tested with 64-bit Linux Mint 19.1 MATE and still same problem. Tried to communicate with Comodo Support and the just replied that they support only Microsoft Windows and nothing else. Regardless that 5 Best Antivirus for Linux 2022 | Linux Antivirus site says below that please contact, they are 24/7 here to help. Linux support should be come from current forum only. So - dear Comodo forum - do you fix the years old issue? I asked Comodo Tech Support to remove the site 5 Best Antivirus for Linux 2022 | Linux Antivirus as they do not support and/or develop Linux version anymore. But as a response the Comodo Tech Support just closed the chat twice while I was trying to communicate and typed responses. For me the Comodo Antivirus for Linux is dead.

Yeah Comodo support is BS… they should take down that site their AV client won’t work because of the outdated packages it wants to use yet they refuse to do anything about it.

is there any solution for this?
I just bought comodo internet security
but then i cant install it?

You can extract the .deb file to a directory, edit the DEBIAN/control file to remove the bit requiring libssl0.9.8, i.e. delete

, libssl.0.9.8 (>= 0.9.8m-1)

then save the file.
Then run

dpkg -b extracted_folder cav.deb

(replace extracted_folder with the name of the directory you extracted it into)
This will build the file cav.deb which you can then install.

CAVL developers, you can easily save everyone the hassle by changing the control file to require

libssl.0.9.8 (>= 0.9.8m-1) | libssl1.0 | libssl1.1

and maybe throw in a future libssl1.2 as well just to be sure :slight_smile:

Install libssl0.9.8 to the system.

i installed 0.9.8 but still have the problem…

and another issue, is that this bug is going on since 2017…
look back posts…

I followed this guide:

I downloaded and installed libssl0.9.8. I got an error that multiarch-support is not installed. I download and installed multiarch-support from the following website: Ubuntu – Error

I try to install libssl0.9.8 and I get the following error: unable to open ‘/lib/x86_64-linux-gnu/’: No such file or directory. No apport report written because the error message indicates an issue on the local system. Errors were encountered while processing: /home/htpc/Downloads/libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb

I extracted the deb and removed libssl0.9.8. I built the deb file. I installed the deb file and it added “control.tar.gz”, “data.tar.gz”, and “debian-binary” to the / directory. I think the files should be extracted to the /opt directory.

I extracted “data.tar.gz” and it add files to /opt and /usr folders. I extracted “control.tar.gz” to the /opt folder. I ran “/opt/COMODO/” script in the terminal to manually configure it. I got an error that “SQLite driver is not installed”. In Synaptic, I installed “sqlite” and “sqlite3”. I still get the SQLite error when Ubuntu starts.

I did the following:
sudo ./
sudo ./preinst
sudo ./postinst
sudo ./cmdagent

If I open comodo, I can run the updater without error.

can you upload somewhere like dropbox or here a tar including all scripts ? thanks !

Yes, you may be able to update it, but i’m sure your file filter driver ist not running, thatfore you’ld have to compile the kernel.
What use does a AV have if it can’t filter incoming files itself and which can only update itself?
The last versions CAVL is running properly on were LM 18.0 and Ubuntu 16.04.
If the Comodo developers won’t keep their promise to release a new CAVL version this program is dead, sorry!
The actual CAVL version is now about 7 years old - so if you want to compare - it’s like trying to install a AV built in 2013 on a new Windows 10 built 1909. Maybe you can install it, but it’s blind like a worm and you should not feel save with it.

I run debian buster, this is what worked for me:

First, check I have a version of the libssl that it’s complaining about (My system currently has 1.1)

apt list libssl*

Then I install the package with the ignore dependency that it’s complaining about.

sudo dpkg --ignore-depends=libssl0.9.8 -i cav-linux_x64.deb

package installed fine, though for some reason said “Uninstallation Succeeded” and not installation succeeded.
from there follow on screen instructions for post installation.