CAV failing to update -- SOLVED

Hi folks,

Have been checking the around the forums but haven’t been able to find a solution . . .

Have Comodo CIS 5.x installed on XP SP3 laptop.
Comodo dashboard says that my virus siganature DB is: 6662
Have made no configuration changes to Comodo.
Over the last few days, I haven’t been able to get Comodo to properly update the .CAV database.

The update goes through its motions of downloaded the updates, then goes through the initialization of the updates. But, it never finishes updating. Instead a balloon message pops up near the system tray with the following:

 Failed to update virus signature database
 Please check your Internet Connection and try again later
 Error Code:  -2147467259

Obviously, my internet connection is fine since I’m able to access the Internet, plus Comodo is able to actually download the updates.

I’m at a loss for why they are failing to be applied.

Any suggestions or insight?

I think I might be having the same problem. I installed CIS on a fresh XP SP3 system over the weekend, and it got as far as signature DB # 6672 successfully on its own. Then I started to get the exact same balloon popups as Naiekim every 5 minutes (unless I turn the balloons off). I tried loading different configs, but none of them worked. Clicking the update button in the CIS GUI, it kept saying it’s up-to-date, but the database webpage says 6682 is the latest?

Today, I tried uninstalling CIS (uninstall/reboot/ccleaner) and then reinstalling (and rebooting). Now it’s stuck at signature DB # 1. Same balloon popup error messages. If I try to update by clicking the update button in the CIS GUI, it downloads the bases file (the progress bar fills up and there’s network activity), but then it gives a vague error message telling me to check my connection.
Edit: I tried clicking the update button a few more times, and sometimes it says the database is up-to-date, sometimes it tries to download the update. Weird.

Here’s another clue from the log viewer. Right now, I get this every 10 minutes:
Type: Av Update
Code: 0x80004005
Old Database: 1
New Database: 1

Back before I reinstalled CIS, I got the same Code # in the log, but old/new database # 6672. A couple of days ago, I got Code # 0x00000001, but I’m not sure about the balloon popup messages because I only enabled them yesterday and that’s when I discovered the problem.

I think I just fixed my problem–we’ll see if it updates successfully tomorrow. At least I got all the latest updates okay.

Using Sysinternals’ ProcMon, I saw that cmdagent.exe was trying to access C:\Windows\Temp and failing. Sure enough, the directory was missing! Really, if Comodo needs a temp directory they should fail a little more gracefully, at least with a meaningful error message…

Naiekim, go into your C:\Windows folder and make sure there’s a Temp folder in there. If not, make one.


Woot! . . . I did as you suggested and – lo and behold! – it worked with no hitches!

Big time thanks . . . and good catch.

Oddly enough, I too, had used Sysinternals’ ProcMon to try and track what CIS was doing – although, I didn’t catch that it was trying to access a “Temp” folder in the C:/Windows directory. I’m not sure if I saw it and it just didn’t register in my brain, or I just assumed the folder was there and Comodo was accessing it with no problem. It never occurred to me that the folder might be missing.

Now, all I have to do is figure out, if the Temp folder in C:/Windows was there previously, how did it end up going MIA – because apparently, Comodo has been using it all along. On the other hand, Comodo also has it’s own Temp folder in:

 Documents and Settings ==> All Users ==> Application Data ==> Comodo ==> tmp

. . . where it temporarily stored the temporary CAV update files prior to integration.

Strange that it should need TWO temp folders . . . but oh, well . . .

In either case, thanks . . . Hopefully, anyone else who has been having the same problem will find this thread.


Just out of curiosity, after CIS successfully updated CAV’s, I waited for a couple of hours; deleted the Temp folder in the C:/Windows directory and then tried doing another CAV update.

Although it did download the signature files, it failed to incorporate them into CIS and gave me the same error message I mentioned at the top of this thread. So, then, I created another Temp folder, tried the update a few minutes later and – voila! – it updated successfully.

So, now we have a positive confirmation regarding what you had discovered.

Again – thanks.

I was having the same problem (“Failed to update virus database” even though the .cav files had been downloaded to the Comodo Tmp directory), and the solution posted here (creating a Temp directory under Windows) solved it. Thanks!

I ran Windows Malicious Software Removal Tool on the day that this problem started - perhaps MRT.exe deletes the Windows Temp directory that the Comodo virus DB update needs.


You mentioned having had the Windows MRT downloaded and run on the day the “update problems” began and that that may have been the “culprit” for the missing TEMP directory – oddly enough, I had come to a similar conclusion because MRT ran on my laptop the evening before I began having .CAV update difficulties, and since I hadn’t made any changes to my system, or added any software, what seemed like the only logical conclusion is that it had to have been deleted by the Windows MRT.

I did check around on MS site to see if MRT does indeed do something with (or to) the contents of the C:\Windows\Temp directory when it runs, but couldn’t find anything definitive to suggest that it does. However, MRT is generally run once a month along with MS security updates and this is the first time the TEMP folder has gone missing.

My best guess is that is was a minor glitch in the latest MRT module – hence the missing TEMP directory.

Well, actually running MRT doesn’t do it. Maybe it was the MRT updater. However, I applied three Windows updates before shutting down on the morning of Nov 10 (and I believe the problem started when I turned the system on again in the evening–unfortunately my CAV logs have rolled over so I can’t check the exact times):

Security Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB954430)
Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB973688)
Windows Malicious Software Removal Tool - November 2010 (KB890830)

Regardless, CAV should handle the situation of a missing C:\Windows\Temp instead of just failing in a strange way.

If I read it correctly, this bug report seems to describe a similar problem happening over a similar time span:

Thank You so much longtime!! I was having this problem also and couldn’t figure it out. I had tried a different file cleaner program and it not only deleted the temp files but also the temp file itself!! Thanks again for solving this one!!