CAS will not open

I’ve now tried to download and install CAS twice from the Comodo web site. It appears to load but, after the PC restarts, the configuration window doesn’t open. I’ve gone into Windows Explorer and double clicked on the .exe file, but again nothing.

I also had previously installed Comodo Internet Security and wondered whether there was a conflict. I’ve uninstalled this, installed CAS and then reinstalled CIS, but CAS will still not run.

I’m using Windows XP Home Service pack 3 and Outlook Express.

Any advice will be appreciated.

Sorry you are having this problem.

Please try the solution at number 3 in this FAQ here.

Essentially CAS is particularly susceptible to a well known XP bug.

If you are running Comodo EasyVPN, this may not work for you, but we are hoping for a new version of EasyVPN soon which we hope will resolve this problem.

Please do tell me if it helps

Best wishes


Programme will run in Safe Mode. Presume there is a conflict with another programme and will have to use selective start up to determine which.

Yes there is. Quite likely with one of the two services I refer to in the FAQ or with Comodo EASYVPN (Just click on the red ‘here’ in the post above and scroll down to number 3).

Best wishes


I’ve now fund a possible workaroud for the conflict with EasyVPN - as yet untested here

Best wishes


I followed your advice at number 3 in FAQ. The taskbar icon appeared and I was able to open the configuration window etc.

Since turning off the PC and returning to it 2 hours later, the icon has disappeared and I’m unable to open the programme again!

Seems a bit hit and miss. Not sure it’s the whole story.

Well some success at least, which means we are barking up the right-ish tree. Sorry you are still having problems. Just to check:

[ol]- have you disabled both the Windows services I suggested

  • are you running EasyVPN, and if so have you tried the steps referred to by item 3 of the work arounds
  • did you install any software on the last reboot (NB microsoft issued an update to XP today, so if you have auto-update set to yes, then the answer is probably probably yes)[/ol]

If you have installed software on the last reboot, then that is likely to be why the problem has recurred. As I note in the FAQ the best thing to do then is to repeat the steps I suggest starting with killing CAS. The problem will probably not the recur until the next time you do a significant installation.

If all the above fail, or if you want a 100% solution, then further investigation is needed. What is likely to be happening is that CAS is opening in the context of program other than Windows explorer - EasyVPN is just a particular favorite. It may even be be installing in the context of a program which is then closed leaving it stranded.

There are two approaches to sorting this you can try:

  • preventing CAS from autoloading. Use msconfig as suggested for EasyVPN in the FAQ but this time disable CAS32.exe and open it manually before you open your client. If this works you can then try adding a link to CAS32.exe (look in program files/comodo/antispam) to Start~Program files~Startup and seeing if all is still OK. Note that if you do this you must not set your email client to autoload. Basically CAS32 must load before the client.
  • determining which program CAS32.exe is loading in the context of. You can use the process of elimination you suggested or, perhaps more easily, install process explorer from sysinternals (just google this, you find it sends you to a microsoft site). Reboot and look at the hierarchical process display in process explorer. If you are lucky you will see CAS32.exe has loaded in the context of a program that’s already open. Then you have a choice of which program to autorun! If you are unlucky you’ll find the program has closed and CAS is floating in the context of the system idle process - then things get more difficult, so come back to me.

A final possibility is clearing the pre-fetch or icon caches, another known source of this frustrating XP bug, but I’d need to look that up! Incidently I have 3-4 programs that behave like this, but CAS is particularly susceptible, suggesting, as you say, some underlying problem. It has been reported as a bug!

Good luck


Hello Mouse1 and I do appreciate your help and advice.

I’m more interested in finding a permanent solution and so installed Process Explorer as you suggested. This shows that CAS32.exe is listed as a sub of RapportMgmtService.exe from Trustee Ltd. This programme is a security programme that I believe runs automatically and safeguards one’s personal financial information when logging onto internet banking sites.

Ideally of course both programmes should run automatically. I’m reluctant to dispense with the banking security programme for obvious reasons. Is there any answer to this so that both can run independently?
Why does Comodo Anti-Spam latch onto another programme, or is this the bug that needs sorting out?
If so, when is a solution expected?


Sorry, that’s Trusteer Ltd, not Trustee Ltd.

That’s OK glad to be of help.

I have Rapport, but its not currently running. So I can experiment. (And yes I do think this is a bug, but I think it can probably be worked around. Fix hopefully in 2.7 release version, but this is taking a long time to release! I’m not a Comodo member of staff, so I have no exact knowledge).

I think what may work is using a batch file to:

  1. killing the CAS32 instance that runs in the context of Rapport
  2. launch CAS32 in the context of explorer, or of cmd.exe
  3. then launch your email progam (if you want it automatically launched)

Alternatively, and possibly more neatly, one could launch Rapport in the same way as EasyVPN, starting the services, then rapport, from a batch file. But being security software this could be complex.

What appears to happen is that CAS32 launches in the context of mail-enabled applications, or services. Probably to ensure it can monitor them if required. When it launches in the context of applications it can close itself. When it launches in the context of services it cannot have a UI and cannot close itself (definition of a service - no UI, unless specifically enabled). Probably mail enabled services were a rarity when CAS was designed.

MY guess is Rapport has a facility to send logs or alerts by email? (Incidently I have had a few difficulties running rapport with CIS - high CPU when Rapport is launched - if CIS is in very high security mode - basically the programs are doing similar things and so probably fight over resources sometimes).

II just need to experiment a bit to see what is neatest.


Thanks for the comments and interest shown.

Until this issue is resolved, think I’ll install and run with an alternative anti-spam apllication.

Yes, I’m not sure Rapport operated as expected today when I did some internet banking and I note your comments about conflict with CIS. Will need to investigate this further.

Will keep in touch

Even if you don’t want to run CAS yet, I’d be glad if you would check if this batch .cmd file works, as it may help others.

It works on my machine! All it does is kill any CAS instances running, then restarts CAS.

Unzip it to your desktop, or anywhere else.

Then drag a shortcut to start~all programs~startup. (You can actually double click on the startup folder in ‘all programs’ to make this easier).

It assumes you keep your programs in C:\program files, but almost everyone does.

If you want your email client to autostart add it to the batch file after the CAS line. (I can do this for you if you give me the file name and path).

If you have any problems you might need to disable the normal CAS startup using msconfig (start~run~msconfig~startup tab~untick CAS32.exe), but I think it will work without you needing to do that.

Best wishes

Good luck if you try it - please do say what happens.


[attachment deleted by admin]

Sorry mouse1, but I’ve already uninstalled CAS and installed an alternative programme. I think the Comodo developers need to do a bit more work on CAS to iron out these bugs. We should be reporting the issues but not necessarily investigating them for them.

I’m also concerned about having to get correspondents to quote a password when they contact me to identify themselves as friendly. I can understand that this may well be necessary with a programme that is based upon the origins of possible spam rather than the content, but I find it obtrusive.

The programme I’m using currently is content-based.

I’ll happily give CAS another try at some later stage to see how it has matured.


Sorry to hear that.

I think the Comodo developers need to do a bit more work on CAS to iron out these bugs.
I agree. The mods keep on asking for development time to be allocated, but no joy at the moment.
We should be reporting the issues but not necessarily investigating them for them.
I respect your opinion, and realise that many people would agree with you. But on balance I think when its free software, users can reasonably asked to do a little bit more than usual. The replication of bugs can be hugely time consuming for developers - I know I used to be one - so if users can give a better understanding of bugs to the developers, it makes it much easier to keep the software free. Eaxctly what 'a little more' means of course is open for debate. But maybe its worth understanding that there are 20 odd unpaid moderators, like me, helping to support Comodo products.
I'm also concerned about having to get correspondents to quote a password when they contact me to identify themselves as friendly. I can understand that this may well be necessary with a programme that is based upon the origins of possible spam rather than the content, but I find it obtrusive.
You might find this works surprisingly well if you tried it - the passwords can be just 4 letters, so maybe take 10 seconds to type. But I agree that the idea takes some getting used to. There is an alternative, less automated policy, which works quite well. The benefits of either policy are very close to 100% spam filtering - no content based filtering can offer this. However I also strongly agree it would be wise for CAS to offer further alternatives, and that the existing policies need improvement.
I'll happily give CAS another try at some later stage to see how it has matured.
I'll look forward to welcoming you back then.

Best wishes and good luck with the content based software!


I’m new to this. Running rapport. CAS wouldn’t run the wizard or indeed do anything after installation. Read the above. went to No 3. downloaded the program. made a shortcut. put it in start menu. watched it run. No further forward.
Any help appreciated.

You need to add it to your startup folder, not the start menu. Go to: Start ~ All Programs ~ Startup. Double click on the startup folder icon - it will open an explorer window. Drag a shortcut to the downloaded program.

Now reboot. It’s possible that the configuration wizard will try and run before my file kills it. Just cancel out of the configuration, my file should start to run (look for a command window), it shoulf kill the existing copy of CAS amd restart it. CAS should the run normally. If not try startng it from the Start menu and report what happens in this topic.

It works for me on XP.

Best wishes


Done all that. No Joy. Here’s the start up file from cc Cleaner
Yes HKCU:Run ctfmon.exe C:\WINDOWS\system32\ctfmon.exe
Yes HKCU:Run PC Suite Tray “C:\Program Files\Nokia\Nokia PC Suite 7\PCSuite.exe” -onlytray
Yes HKLM:Run BluetoothAuthenticationAgent rundll32.exe bthprops.cpl,BluetoothAuthenticationAgent
Yes HKLM:Run SunJavaUpdateSched C:\Program Files\Java\jre1.5.0_05\bin\jusched.exe
Yes HKLM:Run COMODO Internet Security “C:\Program Files\COMODO\COMODO Internet Security\cfp.exe” -h
Yes HKLM:Run RegistryMechanic
Yes HKLM:Run SiSPower Rundll32.exe SiSPower.dll,ModeAgent
Yes HKLM:Run ClocX C:\Program Files\ClocX\ClocX.exe
Yes HKLM:Run CARPService carpserv.exe
Yes HKLM:Run QuickTime Task “C:\Program Files\QuickTime\qttask.exe” -atboottime
Yes HKLM:Run Lexmark X1100 Series “C:\Program Files\Lexmark X1100 Series\lxbkbmgr.exe”
Yes HKLM:Run ComodoAntiSpam “C:\Program Files\Comodo\AntiSpam\CAS32.exe” -q
No HKLM:Run Adobe ARM “C:\Program Files\Common Files\Adobe\ARM\1.0\AdobeARM.exe”
No HKLM:Run Adobe Reader Speed Launcher “C:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe”
No HKLM:Run Eraser “C:\PROGRA~1\Eraser\Eraser.exe” --atRestart
No HKLM:Run UnlockerAssistant “C:\Program Files\Unlocker\UnlockerAssistant.exe” -H
No HKLM:Run WinFaxAppPortStarter wfxsnt40.exe
No Startup Common C:\PROGRA~1\MICROS~2\Office\OSA9.EXE
Yes Startup User cas.lnk C:\Program Files\COMODO\Fix\cas.cmd
Yes Startup User Cas32.lnk C:\Program Files\COMODO\AntiSpam\Cas32.exe
Yes Startup User ERUNT AutoBackup.lnk C:\Program Files\ERUNT\AUTOBACK.EXE
Yes Startup User EzWare EzDesk.lnk C:\WINDOWS\EzDesk.exe
Yes Startup User WordWeb.lnk C:\Program Files\WordWeb\wweb32.exe

After finaly getting 'rid of the “system-slower” Trend AntiVirus on my 4 computers, I was recomended to try Comodo Antivirus & Firewall.

Since I also need a AntiSpam solution I tried to install Comodo AntiSpam afterwards, but I only
manage to run the setup on 1of my 4 computers …

I’m able to install the AntiSpam on all computers, but the 3 last ones will simply not run the setup file ???

I then tried to uninstall the Antiwirus and Firewall, and yes, then the Anti Spam worked ???

My conclution is that this is something that Comodu should fix in new versions, meanwild i installed Comodo AntiVirus/Firewall and SpamFighter and are waiting for a Comodo versions with this problem solved.