Cant update Virus database on New Install of CIS 3.14 or CIS4

Tried for hours today to update virus DB but says check my internet connection. There is nothing wrong with my internet connection - I can do anything I want - well except update the DB! I assume CIS 3.14 is still updateable as dont wanrt CIS 4 at the moment.


Sorry for the delay in replying.

Have you succeeded to update?

I have noticed in the past with CIS 3.14 after failing to update 3/4 times in a row it carries on refusing until I reboot, after reboot updates on first try.


I’m still running 3.14 as well and mine just automatically updated 8 minutes ago.

Uninstalled reg cleaned rebooted reinstalled rebooted did the update - told me I don’t have an Internet Connection. Same issue. Well Comodo might think I don’t but I can access all sorts of sites on the web, use Skype, Update Avira AntiVirus etc.

Any clues why this would be an issue. Have Comodo changed the virus update site from the version contained in the download from Filehippo?

I found the easiest way to solve this is to manually run the SCAN ‘first’ … don’t hit the update now link… that just makes it a bigger problem… this only works on a new install when win sec center says the AV is out of date etc.

Did the scan - still cant update - this is now getting annoying - should I just delete all entries in the registry which relate to Comodo? In fact just did a reg search and found a load of Legacy Entries under System>Control set> enum > root - which I cannot delete. Entries refer t oLegacy cmdguard, cmdagent, cmdhelp etc but it says I cant delete them

Should they be removed for a clean install or not important? All I want to do is update the virus database!

To delete the Legacy entries you need to take ownership over the key; that can be done by right clicking and choosing Permissions and editing.

Do you have other security or network related programs running in the background? Try temporarily disabling them and see if that helps or not.

OMG a nightmare. Cleared all the legacy stuff based on a search of Comodo in the registry. Seemed like everything went. Then thought I might try CIS4 on this PC. All installed fine restarted and tried to update the Virus DB and it failed - message was “I don’t have an Internet Connection.” Well that wasn’t true as i could access anything I wanted on the Internet! How can i find out what is causing the problem - its crazy. Its only Comodo that cant update itself.

In some cases the settings of Internet Explorer may play a role. Try disabling “Automatically settings” for your LAN. See attached image.

[attachment deleted by admin]

Didn’t work. Still same issue. My PC can connect to anything - even the check for updates in the Misc section of CIS4. It says there are no updates. Unless of course its not actually checking.

However, when I choose to update the Virus database it still tells me there is no internet connection. I would have to think that this is an internal Comodo issue as everything else works. Skyp,e IE8, MSN Messneger, Remote Logmein etc

Any other clues? Thanks

Further to my last post - I uninstalled comodo 4 again - used revo uninstaller CCleaner Eusing Reg Cleaner and Comodo system cleaner - rebooted and ran cleaners again. I then reinstalled CIS3.14 and it STILL DOES NOT WORK. I would have to say that this is a basicHP PC with XP home fully updated and has only a few programs on- MSOffice Skype, Windows Live messenger,Adobe Reader, iTunes etc so nothing really uncommon. This is all very frustrating and I don’t understand why Comodo thinks there is no connection when every other program does.

Any help would be grateful as I have wasted many hours trying to resolve what I think should be straightforward.

OK I surrender- Comodo has beaten me. After some 10 hours of installing, cleaning, reinstalling etc etc etc- it still does not work. Every other program on my PC can connect to the Internet. The only thing I can see that does not happen is that if I watch the summary page of CIS - network traffic - no update traffic appears - so to me it is not even looking at the Internet. p seems like a Comodo problem. I could have spent 10 hours looking for another product but persevered to no avail. Now very grumpy

One last go to see if anybody can help - have uninstalled comodo and now running with Windows firewall and Avira.

In my last post it appeared comodo wasnt initiating the update - no cfpudate or cmdagent (if they are the correct ones) in traffic summary. Surely there must be a way to check what is not happening with the Comodo program?