Cant update or check Viruscope version when Viruscope is disabled.

Minor CIS Virusscope bug (kinda)

i tried to check what version i have for Virusscope, but i couldent it was greyed out, i had to enable Viruscope to check what Virusscope version i had in the About page.

added the in Proxy and Host Settings to try the Virusscope 1.8 Beta, but i could not get the Beta update for Virusscope, i had to enable Virusscope to get the update.

A user should be available to recive the update even if Virusscope is disabled and also be available to check the Virusscope version.

I had Virusscope disabled because i was testing stuff, and noticed i could not update Virusscope.

I know if i have the Antivirus Disabled, i will still get signature update, thats why i was expecting the same behavior for Virusscope signature, and i thougt it was a bug.

Edit: Also if a user have a problem with Virusscope they might turn it off and wait for a update to be relesed.
And they might not know there is a new update for it, since they have to enable VirusScope to receive it.

Website Filtering wont receive updates either when disabled.

I find it better this way… pretty sure it’s intended behavior. If AV is disabled, you might still perform a contextual scan… besides that, there’s a separate setting under Updates > Check for database updates.

This can be considered more of a wish enhancement so please create a wish if want behavior to change.