Can't Uninstall ESM

I have been trying to update to the latest version of ESM. When trying to do so it says that the version that i had would not upgrade. I then tried to uninstall ESM. It freezes during the uninstall and stays that way for hours. Sometimes the uninstall process will cause explorer.exe to crash entirely and it has to be manually restarted. Here’s what i’ve tried thus far:

  1. Tried normal Windows removal of program.
  2. Tried killing the associated services and then trying to uninstall.
  3. Tried disabling CISP and doesn’t help.
  4. Tried using Revo Uninstaller and it just freezes.

Any thoughts on how to manually remove this?


Try the following.

First thing to do is to close down everything belonging to ESM using Task Manager. Then check Services (Control Panel → Administrative Tools) and stop service(s) related to ESM.

For problems with Windows installer use Windows Installer Clean Up utility. This tool cleans up all Windows installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed. This tool does not uninstall a program.

Look in Windows Installer Clean Up utility for ESM and when there remove it.

Now the installer of the old program will no longer see remains of the previous version. When no left overs of the previous installer around you should be able to install the new version. Let us know how things go and if problems arise what they are.

Apologies, but the problem was due to Windows System Restore. It appears that System Restore is not functioning properly on this relatively newly built system. Any install/uninstall that makes calls to a system restore point are painfully slow or crash altogether.

The first time this happened is when i was trying to upgrade to the new version of ESM. No idea for sure as to what caused system restore to become inoperable. Now i need to figure out how to fix that. It won’t even set a restore point manually.

So, might not be an ESM problem. Unless in the course of upgrading/uninstalling the previous version of ESM broke something. But of course i have no way to prove that so it is not even worth conjecture at this point.

Thanks for you help. And the lesson learned is “if you have problems installing/uninstalling = turn off system restore.”

Good luck with troubleshooting the apparent problem with system restore. Let us know if you found a solution.