Can't run WoW

I know there was a previous post about someone not being able to run Black Ops, but while I was reading I haven’t seen the actual problem fixer, least nothing I can actually understand, so here’s my dilemma.

So long as Defense+ is on safe mode, soon as I log in to World of Warcraft, I get a message where I have a choice to Skip the warning, or to Terminate the program. Well, obviously I don’t want to terminate it since well, I want to play, but skipping does nothing but make the message come up again and again until I choose to terminate. Or, as of late, WoW will simply close itself out. When I look in View Defense+ Events, I see my WoW.exe file flagged as Shellcode Injection multiple times.

So, unless I have disabled Defense+ until I am logged in, I can’t play the game or it will close itself out. I have tried adding the folder to my Trusted Files, but this still hasn’t solved my issue. Needless to say, I shouldn’t have to disable my internet security so I can log in to a game, nor do I want to. Can someone give me a hand with this please? In simple terms would be nice. Thanks a bunch.

Since I can’t delete my own posts on here, no worries Comodo people, boyfriend figured it out for me :slight_smile: Thanks anyway.

Hey and warm welcome to comodo’s forums!

you need to add WoW in exclusion if I remember right. this is how you do it: CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse… Now you add WoW exe.

this is how you do when you buffer owerflow. if you use deamon tools add it as well in exclusions

Valentin N