Can't run Unite as a Service on Win 7 (v., both X86 and X64)

Can’t run Unite as a Service on Win 7

Trying to use Comodo Unite to manage my home computer when away. In order to do so, I need login at bootup (so that I don’t lose connectivity after a remote restart). Although the manual says that Unite can be configured in Tools:Options:Service to login to the Comodo servers at startup, when I go to the Service tab it says “Windows Administration rights are required to view and edit these settings.” I am using a local admin account. I have tried setting Compatibility for Unite to run as an administrator and have also tried setting to run in XP compatibility mode. Same problem on both my Win 7 32-bit and Win 7 64-bit machines.

Machine 1:
1.CPU: 32 bit
2.Operating System information: Win 7 SP1
3.Actively-running security and utility applications: None (fresh install of OS)

Machine 2:
1.CPU 64 bit
2.Operating System information: Win 7 SP1
3.Actively-running security and utility applications: Symantec Endpoint Protection 11.0.7 MP3

can i just ask, what is ‘local admin account’ ?

is it an account with admin privileges ?

Yes its an account with admin privileges. The computer is a member of a domain. My use of the word “local” meant to indicate that the account I was using was an account with admin privileges on the specfic computer, as opposed to being a domain account.

Hi szametu,

This is normally found on a PC that is part of a Domain ( corporate network ) where user restrictions are set by the IT Management Depart, but you can have a ‘Local Admin Account’ so that you can install programs, run programs, and make certain changes that require an Admin account. BUT you cannot make changes on the ‘network’ and some programs still do not run or install properly.

Hi StevenLawyer,

Welcome to the Forum :-TU

If you only wish to use Unite to mange your Home Computer from another PC that is connected to the internet have you looked at COMODO LoginPro ? once the software is installed on your home PC - or any other PC’s / Laptops you may have, you can log-in to the website and control/manage your PC from there. You don’t even have to install the software on the PC you are using to access your home PC if you are using a Browser that has HTML 5 capabilities :slight_smile:

Dolphin 66:

Thanks for the reply. I am the domain administrator. I don’t have any restrictions set by group policy as it relates to the network.

I am familiar with products like LoginPro. For a host of reasons, I just want a persistent VPN connection. Sometimes I want to move files without establishing an RDP connection. And when I do establish an RDP, I prefer to use Windows Remote Desktop.

Any answer about getting this to run as a service on startup?


Have you logged into the PC as an Admin for that PC and not as a Domain Log-In with local Admin rights?

I had a problem with Unite not remembering the Username and Password properly when the system re-boots and so a connection was not available :frowning: Unfortunately Unite has not been updated for quite a while now, which is a pity, and it looks as tho LoginPro has the development attention.

If the above doesn’t work, I hate to say it :-[, and I don’t know how many PC’s you wish to have setup, but have you looked at LogMe in Hamachi the free version allows up to 5 PC’s on one network, and I think the last time I played around with it you could have it so that 1 PC was actually capable of connecting to two ‘network set-ups’, but this may have changed - as you used to be able to have 10 PC’s on one ‘Network’.

Although Unite may not be quite up to your specific needs at the moment, or someone else may be able to jump in and help, there are some other great programs developed by COMODO so please stick around the Forum :-TU


Dolphin 66:

I haven’t tried logging in as a non-domain admin account (i.e., I was logging in as a domain user who had local admin rights).

I am a five year veteran of Hamachi–it was perfect. As of early November, they intentionally crippled the free version so that it will not establish a VPN connection until after the user has logged in. This makes it worthless for remote rdp–the moment you end an rdp connection you lose the tunnel. That’s what caused me to go looking for a replacement and brought me to Unite.

I guess I’ll keep looking. Maybe tinc . . .

gbridge should be good for you.


  There is one workaround for you:
   1. Create a administrator account for your local computer, not under domain, set password for it.
   2. Login your computer as this new account, and launch Unite.
   3. Set Unite service to auto login in with specified Unite account, and add Windows users which could access the VPN connections, remember adding the account you used under network domain.
   4. Save settings and restart computer to sign with your account under network domain.

   By this workaround may solve your issue.

A workaround is not a fix.
Comodo Unite should not disable the ‘Service’ tab when the currently logged in DOMAIN user is a member of the local Administrators group.
Is there any way to raise the profile of this defect?