Can't right-click Comodo Firewall icon in systray if using ObjectBar

I’m using Objectbar 1.65 from Stardock. ObjectBar let’s you change the windows task bar at the bottom of the screen as well as let’s you change the Start menu. I use it to expand and customize the Start menu and to make the time also have the date in the systray over on the right end of the windows task bar. Otherwise, for me, it pretty much all looks the same as the regular Start menu and windows task bar stuff in Windows XP for me. But I really need to have my expanded customized Start menu which ObjectBar allows me to do.

With Comodo Firewall Pro version which I just downloaded today, I can’t do a right-click on the Comodo Firewall icon in the systray. I have to unload ObjectBar to get the normal windows task bar to do a right-click on the Comodo Firewall icon to get the little menu there. Otherwise, since I want to keep ObjectBar turned on all the time, I have to go into the Start menu to open up the Comodo Firewall.

I have no idea if this happens in ObjectBar 2.0 (because I’ve only paid for ObjectBar 1.x and Stardock is not giving free 2.x upgrades to paid users of 1.x), but I thought I should post this message if this can’t-right-click-Comodo-Firewall-systray-icon problem is also affecting other users who skin their windows task bars and hoping that the official Comodo folks can fix this in the next version of the Comodo Firewall. If this is not too much to ask to have fixed…

Welcome to the forums, ruel (:WAV)

I’m not a coder, but it sounds to me like an issue to be fixed within ObjectBar, rather than CFP. I could be wrong, though. At any rate, Comodo does interact with the forums, and so you can be confident they will see your post. I know there are other users with custom taskbars and no issues, but I don’t know of any with OB specifically.

One possibility to try, just to see if it works, would be to uninstall both ObjectBar and CFP. Clean the registry, then reinstall CFP, and then ObjectBar (with CFP already installed). Of course then, you’d have to reconfigure OB, so that’s a decision you’ll have to make… :wink: Since I don’t know if it works, I can’t advise one way or another; but I know from experience that in weird situations, this process frequently does resolve the issue.

If you choose that route, and it works, then I can add it to my list of “Yup, it worked again…” scenarios. ;D If you choose not to go that route, or if it does not work, I would advise filing a ticket with Support just to cover all bases. Be sure to provide them with a link to this thread, and also keep us posted on their response.


Too much work. Sorry. Might as well not use ObjectBar at all.

The last time I tried Comodo sometime in the past when the Comodo Firewall automatically included that gawdawful launchbar for all the other Comodo programs, I don’t remember the Comodo systray icon having this problem at that time. And I was using the same version of ObjectBar the last time around. Based on that, IMHO, I personally think it’s Comodo’s problem. 88)

In the meantime, the workaround for me is to add a Comodo Firewall icon to the quicklaunch on my windows taskbar to get quick access to the Comodo Firewall.

Anyways, I’m a “tourist” again trying out the Comodo Firewall again. Kicking the tires again, so to speak. This time around what tempted me back to try out Comodo Firewall was how it is claimed that the Comodo Firewall doesn’t leak. But it leaked on me when I tried that Comodo Parent Injection Leak Test. I saw the other messages where it leaked on other people also and the advice given in those messages. So what else is new when the hype doesn’t quite match reality and you have to do more work to get it to operate as advertised. Oh well, no offense, but I probably end up going back to my trusty old version of ZoneAlarm Pro 4.5. ;D

Ah, LaunchPad… yes, there were a “few” complaints about that. :wink: You note, of course, that it’s not here any more!

As to CPIL, I guarantee you that Comodo didn’t create a test their own firewall would fail. In every instance I’ve seen where someone has said it failed, it has been due to user error - misunderstanding how to conduct leaktests, not understanding the alerts given (and thus responding incorrectly), and so on. You’ve got to realize, none of these published leaktests are actual malware, so when you test, it’s just “for grins” so to speak. They are designed to simulate types of action taken by malware, but are designed to be conducted with certain protocols (such as rebooting between tests, always choosing deny, etc). They also don’t take into account any rules changes users may have made, which could potentially decrease security in general.

If you have specific questions about that (or other) leaktests, be sure to post in the Leaktest boards, where someone will be glad to help you. I’m not a big leaktester, but I have done most of them that are readily available, just to see how they work… I haven’t had one fail yet, even on default settings.

And yes, you’re always welcome to return to ZAP 4.5… :slight_smile: