Can't open Twitter and other probl

I get some problems when using the Dragon browser.

  1. After logging in on the website, the page only displays as in the screenshot. (this problem only appears if I have logged in)
  2. After logging in 2.0, the design page only looks like this.
  3. I can’t login Disqus through the comments section of a blog that uses Disqus as a comment.

I have tried it with fresh install, turn off all the extensions and default settings but these issues still happend.
I have used Dragon browser for years but problems arise.

Comodo Dragon is up to date
Version 70.0.3538.110 (64-bit)
Windows 10 64bit


Hi px!

Thanks for your feedback!

Can you please provide us a website example from which Disqus is required in order to comment? As I tried login into site as normal and it worked. I tried all the sites you have provided and for me the logins on these sites worked. Which type of login did you used? User/password or social media? (I’ve logged in using facebook or google, and they both work). Can you also provide more information so we can replicate your problem in order to find a fix?

The Comodo Browsers Team

try clearingbrowsing data caches and cookies then restart the browser