Can't install or update Metro apps Windows 8

Howdy all,
I’m using CIS 6 beta and I have native Win8 Firewall and Defender shut off in services.
My problem is that I can’t update or install new Metro apps. However if I turn on Windows Firewall then Metro apps install and update fine.

Is there a way to setup the CIS firewall to allow Metro apps to function properly?
Would suck if I have to leave Windows firewall on just for metro app updates and such. I already have the firewall in my router and of course the CIS firewall, don’t need a third firewall running. :stuck_out_tongue:

Bueller…Bueller…Bueller…

Anyway. :stuck_out_tongue:

Did some testing. If I shut off Windows Firewall through the control panel, then Metro apps will install and update. However this leaves the firewall service still running.

So, is it possible to totally shut down the Windows Firewall service, and then configure Comodo Firewall to allow Metro apps to be installed and updated??

Hi plywood99,

I found that when I installed CIS 6 beta on Windows 8, it left the Windows Firewall switched on instead of switching it off ( I’ve reported this as a bug :-TU ) and with both firewalls on it can cause problems.

Just have a look to see if Windows Firewall is still on, if so you can turn it off and see if this helps?

Thanks for reply Dolphin, but as I stated, Windows Firewall MUST remain on in “services” for Metro apps to update or install. It’s not a problem between CIS firewall and Windows firewall.

Hope I’m making my self clear.
If you want to try for yourself simply do this:

  1. install CIS 6 beta
  2. got to services.msc, disable Windows Defender and Windows Firewall.
  3. Try to install or update a Metro app. it wont work.
  4. Go to services.msc and turn on Windows firewall. Make sure its running. Now go to control panel, Windows Firewall, Turn off firewall for public and private networks.
  5. Now try again installing metro apps. They will work perfectly.
    Note that in order for Metro apps to install or update the Windows 8 native Firewall service MUST be running, even though its “turned off” in control panel.

I can’t explain it simpler than that. Hope this helps.

Hi plywood99,

Sorry for the confusion :-[

If you go to the Microsoft Community page here in the second reply there are some links to explain about the Windows Firewall Service.

Hope This Helps

Bob

Ahh that explains it. Thank you!
Maybe is just me but seems kinda silly for MS to tie so many other features into a service that’s labeled “firewall.”

While an old thread, some information needs to be made clear:

The Windows Firewall service must remain started set to automatic, regardless if you have a third party firewall installed. This doesn’t necesarily apply to the above steps as the reader is instructed to re-start the Windows Firewall service after stopping it.

However, turning the Windows Firewall service off, and most times leaving it off, crops up in majority of threads I’ve come across dealing with Metro Apps and HIPS/Firewall issues. The Windows Firewall service must always remain started and set to automatic, however this does not mean you cannot turn off the windows firewall via the control panel. These are two entirely different things and do not affect one another. The Windows Firewall service has deep hooks within Windows and controls a multitude of different functions, even when the firewall is turned off in the control panel due to a third party firewall being used. For example, the Windows Firewall service is required for endpoint mapping, which is required for sharing printers. Try to share a printer without the Windows Firewall service started and you’ll receive an error there’s no more endpoint maps available (this single issue has hundreds of threads dedicated to it with most not realizing what the actual problem is).

That’s exactly what I was stating. Firewall service MUST be running. Logic would dictate that the service be set to automatic.