Can't install CIS

I have tried to install CIS two times on Windows 7 64 bits and I get a black of screen at the start of windows just after the screen for logging into windows

A. THE BUG/ISSUE (Varies from issue to issue)
=> Answer is I installed CIS last version downloaded today on this website

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
=> After the 2nd installation I tried to disactivate BBlocker, the sandbox, HIPS
I have only let active Firewall and Antivirus
I tried a clean install and an installation above an existing and working CIS installation (version 3).

Program installed with a direct influence on windows:
Directory opus (I tried to remove the explorer replacement)
Process Hacker

Anyways, I have Paragon so I can retry to install CIS without fearing to loose my system (cause there is no way to repair the black screen). So if there’s a way / an option added that is crashing totally windows that I could remove tell it to me…
Precision: the task manager crash when I tried to run “explorer” from it…

Other precision: With the safe mode, I have run Regedit and I have seen that the HKLM/Software has totally disappeared except COMODO entries…

Hi and welcome Ralendil,
If I am reading the issue correctly it appears as if you have tried numerous failed CIS installations.
If this is correct please try the following.
I would consider trying a fresh uninstall/reinstall, in between uninstalling and reinstalling run the unofficial Uninstaller Tool for Comodo Products in Windows Safe Mode if possible.


it worked… except that it killed my internet

so I used Paragon to restore my system for the third time… and get tired of this…

so I bought Kapersky
As I loved Comodo, I will retry it in one year and see if the black screen of death is gone…
precision I use Comodo for almost 5 years

Hi Ralendil,
Sorry to hear that issues persisted.
We probably/maybe could have worked out the loss of connection, but I do understand your frustrations.
Thanks for your support and I hope the future brings better results for you.
Kind regards.

I haveing a similar problem, but getting grey screen, just downloaded today …may be following your lead …

Sometimes it happens that you can’t connect to the internet after uninstalling, using the unofficial clean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.