can't get vpn to work


after installing Comodo Personal Firewall I cannot connect to the VPN from my office, and when I try to, it shuts down my internet connection, can you help me ?

There is a default setting on the MS VPN connections to put all internet traffic through the VPN… which is why you feel your internet connection stopped working… unless changed, all traffic flows through the VPN wich you do not have rules set to enable traffic through yet (I imagine).

Although I have not yet tried to setup my VPN connection to my new office… I can imagine that you would need to:
A) Setup a new Zone for the IP address range of the network you are VPN’ing to
B) duplicate a set of network rules (from your current Home Network) for your new “Office” Zone

This of course also assumes that your IP range and your “office” IP range are not the same (i.e. 192.168.1.X)… if that is not the case, you may be using an IP address already in use, and that will kill your hopes of a connection.

I just checked this FAQ section and found another user did something very similar to what I’ve sugested to get his VPN to work… [url],806.0.html[/url]

Actually, the problem was not with yhe VPN, as it turned out, but with the residue of Zonealarm, which I had not completely uninstalled. The presence of a vsdatant.sys file in an indication that this is the case. To get rid of it you will need to reinstall Zonealarm (having first unstalled Comodo Firewall), then do a clean unixtall, as per the instructions found here,
be sure to do everything suggested and afterwards verify that there is no vsdatant listed in the hiidden non plug and play devices. This solved a lot of problems for me

good job! ;D

It’s nice when you can find the answer to your problems with some elbow grease.

Thanks for sharing the solution with the community!

Thanks for digging this up, Gustav. There are a couple of other users on the forum switching from ZA and are having problems installing CPF. I’ll pass on tihs link and see if it helps them out.

Thanks again,
Ewen :slight_smile:



  1. go to Firewall tab
  2. click on Attack Detection Settings
  3. Click on miscellaneous tab
  4. un tick “block fragmented IP datagrams”

Thanks for the advice, but let’s lock this thread. It is over 18 months old. :slight_smile: