Can't get VPN to work in v3 [Merged Threads]

Operation System: Vista Ultimate
Symptom: unable to connect VPN(windows 2003 server), no prompt, no log event , both with monitor other NIDS protocol option enabled and disabled.

After upgrading to V3, I can no longer connect to the PPTP Server at my office. I uninstalled V3 to test and the connection works fine. The client does see the server but it can’t authenticate. I’m sure I’m doing something wrong. Thanks for your help!

Windows XP SP2
Nod32 2.7
Connected Via Cable through Linksys Wireless Router
Logged in with Administrator rights


I’m having a similar problem.
My ADSL connection to internet is PPTP VPN. No wireless components.

With Comodo Firewall v. 2.4, everything was quite simple: install it, and connect to the internet.

After the notification that there was an upgrade (v.3), I downloaded and installed this new v.3 ; I tried the advanced (defence+) option, but no way connecting to internet!

I un-installed v.3, re-installed v.2.4, and there I was: online again!

Then I un-installed v.2.4, re-installed v.3 (but now only the basic firewall), and again: no internet connection possible.

Working again with v.2.4 now, I’m wondering what I did wrong… (:AGY)
(noooo, I did not click away the screen that notified me that v.3 had detected a new network).

Or is v.3 only for specialists, and not for (experienced, but not specialized) home users like me? It sure looks impressive, but without internet connection it’s useless for me.

Config: Windows XP Home SP2, with all updates, admin. rights, AVG anti-virus.

Could anyone help, possibly in not-too-technical terms, as I would like to use v.3 also on my new (second) computer-with-Vista?

Thank you!

I am having similar problems. I have v3 installed with both Firewall and Defence+ running. With the firewall disabled I can connect to my VPN no problem. With the Firewall enabled it will fail. I am pretty sure that even then it did actually connect once but I certainly cannot get it work consistently unless I disable the Firewall.

I do have the IP range of the VPN set up as a trusted network.

All help much appreciated.

Cheers Mike

Is anything being shown as blocked in the logs when you try to connect?

If you don’t know which ports are being used then clear the log and try to connect again then check the log to see if something is getting blocked and write a rule for it. Make sure it is above any block rules in the Global rules list.


I never saw anything in the logs that seemed to coincide with the attempts to connect to the VPN. However I did see the System, svhost and System Idle Process where occasionally being blocked. Elsewhere on this forum it says that you need to give those three processes more privileges or you can make them Trusted Applications (this seems to be not necessarily recommended).

I made them Trusted Applications to test it and I now seem to be able to connect to the VPN. I will keep monitoring the situation and will report back if anything else crops up. In the meantime if anyone else has any info on this please let me know.

Cheers Mike

same problem…log file attached…the forum upload won’t allow .htm files…so, change the .txt file to .htm or .html and then you can view the HTML log file

note: prior to 8:17pm, I didn’t have a rule or logging enabled for the rule that was for incoming from the VPN server external IP…after 8:17pm, I did.

The generated log file didn’t dump the protocol, which is “GRE” for all of these.

The weird thing, is I explicity said in my 4 rules: “ALLOW” — see following 4 rules:

Allow & log IP in/out from my home zone to VPN server external IP where protocol = 47
Allow & log IP in/out from VPN server external IP to my home zone where protocol = 47
Allow & log TCP or UDP in/out from my home zone to VPN server external IP any source/destination port
Allow & log TCP or UDP in/out from VPN server external IP to my home zone any source/destination port

and it logs them…but I set it to “ALLOW”!? what’s up with that?

MikeDymond’s temp workaround works for me too…thanks…

only System Idle Process needed to be trusted for mine to work…

I think we still need a better fix, because, as stated, making that process trusted may not be a good idea…

Thanks for the responses! I added System Idle Process as a trusted app and I can connect to my VPN server now. Seems a little weird though. There probably should be a better solution than this. I don’t think I’d consider this resolved.

I removed your .txt file as it had your VPN server IP.


Comodo V3 has killed my VPN connection as well as my Internet Connection Sharing.

Still no joy with VPN. Anyone have any suggestions how to make it work?

Nothing here either. I tried making the System Idle Process a trusted application, but it didn’t work. I had no problem with the old version.

Anybody come up with a good fix yet?

I am having the same problem. Not sure what to do now.

Same problem here too. Been running my internet through VPN with ver. 2.4 without any problems what so ever. Upgraded v. 3 today, since then struggling to get my VPN to work again. Tried the above suggestion with no luck. Still getting error 619 when trying to send username and password.

I won’t describe myself as an expert but no newbie either :wink: but gave up and wen’t back to 2.4 and everything’s running smooth again.

Seems as if more VPN users have this problem so maybe an issue to look into?

V3 looked pretty nice though.

I also have the same issue with VPN not working. I tried the suggestions but none of them worked. I tried installations with and without Defense+ but still had the problem. I also managed to crash Commodo twice (once when I was adding the address of the VPN server) and once when I clicked on one of the help links … ‘what do these settings do’ or some similar text.

I’ve gone back to v2.4 which works fine since I need VPN access to work remotely.

I’ll look at upgrading when the problem is resolved in a later version.

Making the system idle process trusted worked for me, but I don’t like it!!

Where are the Network Monitor logs? All I see is the application logs and those have not told me anything.

I’m really thinking about going back to Vr 2.4 until the bugs are worked out.

VPN connection gives error:

Error 619: A connection to the remote computer could not be established, so the port used for this connection was closed.

If disable firewall then connection will be established.

Help :slight_smile:

COMODO Firewall Pro
Vista x64

Sorry for my bad english.

A thread already concerning this issue runs here

You could try the suggestions in this one thought it dosn’t seem to work for everyone, me inculded sadly :wink:

I also had this problem. Tried a lot of things to make it work but none of it worked. Maybe a problem was that English is not my mother tongue, which made it quite harder to set right configurations also by using a dictionary…

But using VPN is essential for my study where I’ll need to connect to the server of our studying project.

Therefore I have reinstalled version 2.4 - there it works fine.

I will wait until the bug is fixed…