Can't get Comodo Dragon to use Comodo Secure DNS - DNS

Yes I have “Enable malware domain filtering (Comodo Secure DNS)” checked.

I even uninstalled it & made sure that "I would like to use Comodo SecureDNS Servers (in Dragon only)’ is selected.

My system DNS is OpenDns.

As a test I tried going to GameSpot and OpenDns banned it for me. (Game site)

If Comodo Dragon was using Comodo SecureDNS Servers, then it should go to GameSpot with no trouble.

It is not using the Comodo SecureDNS Servers, and OpenDns blocks GameSpot.

I even changed my system DNS to Comodo SecureDNS Servers. And yes, Comodo SecureDNS Servers were working.

I had Comodo Dragon on my computer before & it used the Comodo SecureDNS Servers.

I don’t know which version it was.

What gives?

Hi and welcome Lassar,
After selecting ‘malware domain filtering (Comodo Secure DNS)’, please try clearing your browsing data from the beginning of time and relaunch Dragon. Ctrl+Shift+Del


I cleared the cache & it didn’t help.

I even ran a command prompt as administrator running “ipconfig /flushdns”

No help.

It makes no sense. I have two vistas on my PC. One on a fresh hard drive, and one on a very old
hard drive.

The Comodo Dragon on my old hard drive is working properly.

I think the Comodo Dragon versions are identical. The version number is 33. I think it is the same version on both drives.

Is there a Comodo Secure DNS test page to see if Comodo Secure DNS is working?

Hi Lassar,
Try disabling all 3rd party extensions.
It might be worth trying a new user profile.
To create a new user profile in Comodo Dragon-Comodo Help
Other than that I am not sure what is happening, sorry.

The following external link will give the origin and a description on what DNS settings the browser is using.
Click on the second b[/b] to view more information.

Kind regards.

Did as you suggest. Created a clean profile. Turned off extensions.

I tried and got 2a02:1788:806:193:384e:6aff:fed6:e252 for the DNS address.

When I restart detection in it, then it shows

Hi Lassar,
I presume it is correct as I get the same result as you.
At the time of posting this the direct download link in reply 393 of the following link is still blocked here by Comodo Secure DNS.
I would say that is a safe link to test that Comodo Secure DNS is functioning.
Report Blocked Sites You Believe Are Safe Here

Kind regards.