Can't get Activation License no matter what I do [Resolved]

I have been attempting to obtain a license for activating Comodo for close to three weeks now. I would greatly love to try the firewall, but I don’t know what else to do to obtain the license. I tried the website: it allowed me to download the .exe file but that’s all. I obtained a ticket number and contacted customer support - no luck. The last email I received from support gave me an order number. I then received an email that stated: “Your licence will be issued shortly and emailed to” [my email address]. That was on October 15th. I have received no further emails providing me with an activation license. I keep being told to try the website again, no matter how many times I’ve told the support person that for whatever reason it doesn’t work for me. I guess this is my last attempt to resolve the issue, as I’ve reached the point of total frustration. Since support hasn’t been able to resolve it, perhaps there is an administrator here in the forums that can help me reach a solution. I would appreciate it.

Hi and welcome to the forum. I have sent you an activation code and you should get it in no time. :wink:


Thanks. I received your email along with the activation code and look forward to trying the Firewall. Since I have read so many positive reviews about the product, I am looking forward to using it. Thanks again.

You are very welcome. :wink:


Well, I tried activating with the code, but to no avail. After I pressed the “activate” tab, the program stated it was registering the product with IE internet options, etc. I then received an error message (although I didn’t write down the numbers that followed). I am wondering if it is required to have ActiveX enabled in order to register (which I don’t). I never use IE and have it locked down, and can’t imagine why ActiveX would be required to register a program. Perhaps that’s not the issue, but at this point, I can’t register Comodo. I specifically asked the support person I was working with about the ActiveX issue, but that question was never answered. Any suggestions or tips to get this resolved?

The IE issue. Do you have it actually disabled\uninstalled or just not using it? IE is still a part of the Windows system and unfortunately , for updates and other things, it is required. I can’t run just Firefox with IE at least being on the system. Well, I could but many things don’t work. IE is safe as long as you aren’t using it, lol. The new IE7 seems very good, I admit. I have had that installed instead. Many other programs require IE for OLE attempts and if no IE , no go. Like I said, keep it enabled, simply don’t browse with it. That’s what I do and it works fine, I even have it hidden from the desktop. I questioned Firefox at one time, not badly but because according to my firewalls i’ve had, it uses IE for certain internet attempts and may be why you can’t register.


My IE (IE 7) is enabled, and I have to use it at times at various secure websites that don’t play well with Opera (which is my primary browser). By “locked down,” I mean that I have protections enabled by SpywareBlaster as well as ActiveX disabled, etc, per instructions at several security websites. In other words, I’ve tried to make it as secure as possible, yet keep it functional. That being the case, what do you believe could be causing the error message and not allowing the registration process to take place?

Have you tried to temporarily set your CPF settings to Allow All just to get registration through? There were some scattered issues with this. As well, I don’t disable Active X, I just watch closely. In 8 years never had a problem. I would enable it and see if activation works, you can always disable it. A major problem I see is the growing trend of being so safe, that we can no longer use anything. I don’t like this trend and it simply limits user ability. I have never had a virus, take over, in all my time with computers\browsing. I just use common sense, if a person goes to sites they shouldn’t, then don’t blame ActiveX, or java etc…not saying all do but many hit porn sites, come to me with their computer crashed and say how they hate their browser, security, active x etc…but had they not been on ACTIVE XXX, this may not have happened. Anyway, I am not saying you do, what I am saying is that if you are a watchful browser, pay attention to changes, I can’t see disabling ActiveX. This is only my opinion though. You sound knowledgable and take precautions. Some hijacking etc…takes place , false Active X , all sorts of rotten scripts, but we take a chance no matter what we do. If you read in CAV release, Melih has some very interresting info on what CAV will be doing and I think you should stop in and read that. It may make you feel better.


I think I found my answer in another thread. I wanted to mention this just to possibly help others who are having the same problem. I use the HostsMan hostfile manager, and the secure Comodo website address was listed in the hosts file blocking list. I guess there used to be some problem with Comodo that has since been resolved (according to some articles I read), therefore the listing in the hosts file. I removed the entries from the hosts file, and am going to give this one more shot. However, I read in another thread that the activation didn’t work with IE 7, and to use IE 6. However, I can’t see where there are separate Internet Options for IE6 and IE7. So even after unblocking the secure website in the hosts file, am I going to have to uninstall IE 7 in order to register? That’s kind of a pain. This sure has been a lot of work just to register an application… But, like I said, will try one last time.

I can show you this so you know i’m not just saying so. I used IE7 and activated. I then installed Firefox of course as I still won’t use IE7 for main browsing. It’s been nice without constant spyware so i’m sticking with FF. I think some of the issues were Launch pad being accused of being spyware. It only linked to news and it’s own products, update, etc… Is this what you read? Most were corrected on this issue. There are some little sites that still claim Lauch pad as spyware and even though no longer being a part of the future and Comodo taking it away, this site still insists. lol. It may do so long after lauchpad is gone. ::slight_smile: Dont’ know. What version of HostMan do you use? The latest I saw was a BETA. This may have something to do with it as well. Unless you use the stable version of course which still may NOT be updated to allow Comodo\block automatically. If they consider Comodo unsafe, I will unleash my moderating fury and e-mail them pronto. <ooooh scary huh? ::slight_smile: I just downloaded it and I do use things like this if it’ll help me understand your issue better. I’ll get in touch with them if in fact this is the case in the latest beta version. :wink:


[attachment deleted by admin]

Well - Success at Last! The host file entry was the problem. I went into HostMan editor and found three entries for Comodo, one of which was the “” that the registration process needed to access. I un-checked the entries, then entered my key and hit the validate button, and my key was validated immediately! Kind of feels nice to finally win the battle with this problem. As far as the original of the hostsfile entries, I can’t say for sure from which source it came, since I use HostsMan (ver 2.1) to download updates from hpHosts, MVPS hosts, and Block Adverts. Since the new entries are all merged into the file, I can’t say from which site the entries came. All I know is that they were in there. I knew was in there, as it had always blocked me from accessing that site. Anyway, that was the problem. I also put this in the other thread that concerns the same problem so others can check and see if dealing with he “blocking” issue will allow them to resolve their registration also. Anyway, thanks, and if I can help answer any more questions when you look into this, I’d be happy to do so. Am happy things finally worked out.

KDNeese, this is great to hear! :BNC

I downloaded the beta version and it WILL ignore Comodo now :wink: JFYI.
Take care, feel free to stick around the forum anyway :wink: