Can't Download

Hi Guys
Can anyone tell me if the Comodo download site is down cause I tried to download CIS 3.9 and it cant find the page. Also tried to download 3.8 and it says that it cant find the page. I tried it with both firefox and ie7. I am a bit concerned because I cant do a virus update and it says that it " failed to update…, Please check your internet connection and try again later. Obviously I am on the net otherwise I wouldnt be doing this post. I can get to the Comodo home page with out a problem and go straight to the download section for CIS 3.8, do all the correct clicking and cant download. Does anyone know what is going on.

You can get the 3.9 RC here: .

I just tried downloading from the download page and it works. The site has been redone and is up a not more than a week. May be a glitch?

If the problem still persist could you give us the url’s to test?

This thread is in the wrong board.

Shadha requested the beta, which makes this board the right place for the thread.

Thanks guys, I ended up formatting my laptop and everything is fine again.
Thanks again for your responses.
shadha :slight_smile: