Can't connect to web interface

i installed my ztl (centos) and i can’t connect to the web interface to configure it.

after instalation i use the https://(the ip of the server):10000 and it’s not working


Please check ZTL service’s status:

service ztl status


netstat -tanp | grep 10000

I am having the same problem:
service ztl status
ZTL (pid 3547) is running

netstat -tanp | grep 10000

tcp 0 0* LISTEN 3547/perl

Please, check your firewall rules:

iptables -L INPUT -na

Please, try to connect to http:
http://(the ip of the server):10000

What message displays browser?

Hi I am having exactly the same problem with the same responses as the previous user …
On checking iptables -L INPUT , the results are: source: anywhere destination: anywhere - so no ip rules are blocking access … but when i try to access the server from a remote machine on the network, it eseentially times out and no page is displayed on any combination i.e. http. https - although i can ping the machine and it responds fine.

Really look forward to getting it to work soon … :slight_smile: All help will be much appreciated.


Please, post result of this comman on your ZTL-server:
echo -e “GET HTML/1.0\n\n\n” | nc 10000

And check ztl logs:
tail -f /var/ztl/miniserv.log
tail -f /var/ztl/miniserv.error

Ok tried the command with the “Get” - the following results were displayed:

HTTP/1.0 Bad Request
Server: MiniServ/0.01
Date: Tue, 22 May 2007 09:11:20 GMT
Content-Type: text/html
Connection: close

Error - Bad Request

This web server is running in SSL mode. Try the url https://localhost.localdomain:10000 instead

When i try to view the logs:

  1. The /var/ztl/miniserv.log file comes up as “cannot open - no such file or directory”
  2. the /var/ztl/miniserv.erro files comes up with lots of text - something to do with the “vendor_perl” directory files - compilation aborted at (eval 7) line 1. and the final error is the one listed about trying to connect via the https://…


Problem sorted - did a fresh install, and disabled (i the SELinux), seems to be working!! :slight_smile:

Can’t wait to dig in and see what this is all about now … looks very impressive!! I will definitely be posting my findings - and will definitely be recommending it for my small business customers … although it would be nice to know how the licensing fee will work and what it will cost too.


I see ZTL is working. Probably you are using proxy connection to Internet in your browser. Or maybe you are using some firewall on your remote machine.

Please, post your ZTL log directory content:
ls -l /var/ztl/

i Found that when using the .iso install if i ticked “everything” in the package part of the install, i could not login to the web interface.
not ticking anything at all and just doing an install with no security and firewall it was o.k
then i could change settings as needed.
i also found that if i did not config the second nic before hand then used “Download, install and configure Firewall, DHCP or Proxy WEB Server” in the web interface, i was locked out of the system.

problems solved now, but thought i would just post this as example.

Yes, if you have configured Firewall Appliance, problems with access to web-interface from remote host can be. Automatically generated firewall rules can’t cover every possible configuration of the network interfaces.
If you have configured Firewall Appliance and you have some access problems, you should stop firewall service and change ZTL rules. You can use ZTL Firewall module ('Network and Internet Management ’ → ‘Firewall Management’) or change /etc/sysconfig/iptables file manually.