Can't Connect to printer


I noticed about 2 weeks ago that I can no longer connect wirelessly with my laptop to any of the printers at the school that I go to. It has been running fine with no problems for the last 12 months. It is running Windows 10 Home edition. I have already tried to shutdown Comodo, but surprisingly, that does not fix it. What does fix it is if I uninstall Comodo Internet Security Pro. I am wondering if there are any other settings on Comodo that I can try to modify or disable since I would really like to continue using Comodo but am uncertain as to what things would be safe to try. The IT guys at my school are not sure on what can fix it either but I was glad that they at least pinpointed it to Comodo blocking communication with the school’s printers. I attached a picture of what happens when I try to print a Microsoft Word document.

Thanks for any help, and I can also post other screenshots of other relevant data if needed.

Check the CIS Firewall logs to see what connection gets blocked when you start printing a document.

Forgive my incompetence, but I’m not exactly sure how to do this, but I will post some pics of what I think may be relevant. The 1st pic seems to be the Events Summary Log (which seems to have nothing), and the next I think is the Firewall Events Log. I took snapshots of these after I re-installed CIS, and then tried to print a Microsoft word document.
Another thing I noticed is that when I uninstall CIS, then re-install it, I am presented with 3 options which I will post a pic of it. If I un-check the 1st option which says: “Change my DNS provider to Comodo secure DNS”, then my laptop can communicate with the printers again. But I’m wondering why this option causes problems now (and remains a problem even after I shutdown CIS), when more than 2 weeks ago, I was able to communicate just fine with our school’s printers?

You did it right, it was the Firewall Events Log that I meant.

As I don’t use that 1st option (“Change my DNS provider to Comodo secure DNS”) myself (I have it un-checked), I can only guess why you can’t print when you have it checked.
Maybe best to keep it un-checked (un-checked means: use your own ISP DNS service), but that’s your choice of course.

Thanks. I’ll just leave it un-checked then.

I have this too on win 7 64 bit. Not sure if i should make my own thread. Apologies if i should OP.
I have logs
My computer is and is trying to make UDP connection to printer. I found the rule and changed it. And deleted it but still won’t connect . Have to disable FW to connect.

I don’t believe that a device can have that address. That is a broadcast address.

I wondered about that see the screenshot. Also, it connects when FW disabled so must be the right address. Broadcasts are needed to find printer.

You could try to delete all Network Zones in CIS and than shutdown / power-off / turn-off you computer and then wait for a few minutes before power-on / turn-on you computer again to start windows and let CIS detect the new Network Zones for you automatically (may take a while before CIS detects them all). Make sure you computer is connected to your network / printer before turning the computer on and starting windows.

But before trying the above, backup / export your CIS configuration first just in case…

OK found it it was a blocked application. Thanks

@OP hope you get sorted, sorry if i hijacked

See here Manage CIS Configurations and here Personal Configurations how to export and import CIS configurations.