Can't complete download with comodo running

i have been experiencing very slow download speed since installing the latest version of comodo.

Downloading of files will stop before completion. The initial file transfer speed is ok for the first few percent before slowing down to 0 kb/s and stay there. When I try to view any videos on youtube, they load very slowly before eventually stopping completely (shows “Done” in the status bar, instead of “Transfering data …”) I know its comodo’s problem coz when I shut it down completely, things return to normal. My comodo settings are “on access”, “safe mode” and “clean pc mode”.

I’m using FF3, but it appears to be the same with IE. I’m using a T1 connection. Is there any settings I need to tweak in comodo?

Thank you.

have you tried setting the firewall to training mode and start a download, let it finish and setting it back to safe. You can also do the same thing with D+.

I tried but didn’t work. Could it be because there’s no entry in My Network Zone?

yeah, that would be a problem. try going to misc tab at top → settings → is automatically detect new private networks checked? if not check it and restart. See if that fixes it.

It was already checked. Anyway, I uncheck, restart and then check and restart. It didn’t detect any network. I tried that again, this time first disabling LAN, start COMODO before enabling LAN.
Doesn’t seem to do anything…

Try uninstalling CIS then do a clean install.

I did a clean install. There is now a loop back zone in My Network Zone. Nothing else.

Could it be because UNS.exe is blocked? I saw this in the firewall events. How can i unblock this application?

Firewall/Advanced/network Security Policy locate and select the file.
Note from what I can find, you don’t require UNS.exe to run.
When you rebooted after the clean install, did CIS detect your network? Did you allow it?

I checked that but the file is not there. Its was shown as blocked in “View Firewall Events” together with svchost.exe. scvhost shouldn’t be blocked (I think). How can I unblock it?


Firewall/Advanced/Network Security Policy.
Locate svchost.exe, select it, Edit/Use Predefined Policy, select Outgoing Only from the drop down box. Click Apply and Ok.

the svhost is already set that way…