Can't Boot Windows

Ok. Where to begin.

Sunday Night I got an corruption error during autoupdate. Just ignored it…um my huge mistake.

Monday morning got the Hall.dll error. This I’ve dealt with before; so, fired up the Recovery Console & began hacking away. Noticed the boot file was missing, next the kernel. Even Symantec Restore wasn’t functioning. Just over 1500 system files were gone.

Got my reinstall cd from Dell today. Have done a rebuild install. Now when I go to log normally or in safe mode it starts with a brief flash of the install/unstall wizard for Comodo and then automatically logs me out. This occurs under user & admin accounts.

Edit: I don’t mean Windows update but, CAVS auto-update.

I need to know how to disable or uninstall both CPF & CAV from the recovery console?


I don’t believe there is a way to uninstall CAVS or CPF from the Recovery Console, or any other application. The Recovery Console is a part of the Windows OS to recover parts of the Windows OS. If you could somehow get into safemode, then disable the CPF and CAVS applications from startup then go into regular boot mode and get in you should be able to uninstall fine. But that is an if this is the first case to my knowledge that a Comodo product has done this, and I can’t really bring myself to bring myself to believe it has, it is possible that a virus/malware program has done this to your PC.

Hi, While I won’t say either way as well, and haven’t heard this from Comodo either, I will say this ,I agree with Justin, sounds like a typical infested hard drive and when installing security software, windows patches, or other means of safety, this will happen. The Hal.dll was probably corrupted by virus activity. Knowing your Dell is OEM with the rebuild, there isn’t a lot you can do with OEMs unfortunately(you get what you pay for) OEMs are very limited, I have them as well. I could have taken you through a process of repairing the Hal, Kernel, but it most likely won’t work with your system and I think this is either virus corruption or hard drive with bad sectors. When the boot file dissapears , it’s not good. If you can get a Knoppix CD (free open source) and \or have someone create one, you can use it to make a boot file and can even copy one from someone and replace the text with your pc specifics. However, having the rebuild CD, I would use Knoppix, to either (if in doubt) run virus check on your system, or uninstall CAV if you feel this is the issue, and\or retrieve your info, and do a complete restore(destructive restore \fresh install) . I have dealt with these types of issues many times, and while I ran across MANY things that seem like a coincidence, would install something and boom, crash, hal.dll, the whole shabang, it’s usually a bad drive or virus activity. That’s my suggestion and Knoppix is excellent. I have used BartPE , it’s like Windows\Knoppix combined and is free to build as well, and has virus scanning , etc…as well. You need to download and burn .iso file and make bootable, it boots right to RAM so your hard drive needn’t be in use unless you access it from Knoppix\BartPE.



I’ve experienced the Hal.dll issue before & know a few different ways to tackle that. None of which worked. I’ve done both a windows & Dell disk check which of come up good (these aren’t always accurate).

I’m not blaming CAV for the entire problem. However, my not dealing with the problem when I received the error message is ultimately to blame for any further cascading file loses.

Malware potentially is the problem that I thought since the kernel was missing. Maybe I have too much faith in CAVS and CPF but, have been running them for almost a month without any changes to my browsing patterns or problems otherwise.

If you suspect you have some sort of malware infection, try EMCO Malware Destroyer its free. But, the download is tucked way down at the bottom of their lengthy downloads page.

Hi, I see. It may not be malware as I stated but the possiblity is there. To be all honest with you, when I begin getting this, if it keeps happening, I would assume a bad hard drive. What happens is when you reinstall, Windows ignores bad sectors, and builds around them. Also, Windows will sometimes ■■■■ out as well. This happened on my son’s pc just a few months back and then again, then again, no CAV on his machine, eventually it was the drive. Although rootkits can cause havok as well. I don’t know what you have installed etc…but I still suggest Knoppix , take off info, do a fresh install.
I can’t rule out CAV either though since you were updating when it happened. As far as faith goes, I know of issues with both but perhaps then wait until next build of CAV to come out. CPF seems steady and running strong. It’s hard to say right now what caused what so I would suggest not running CAV for a period of time and see if this happens again. If it does, then most likely will be pointing to something else. I would also like to note that I have seen even fresh installs after infection by some malware, virus, etc…that linger and need a heavy disk wipe to rid them. I am Sorry I couldn’t be more help on this.


I’ve had rootkit before; thus, my experience with hal.dll. It may be as simple as the linked solution.

Thanks for the help/tips.

I know the reinstall worked but, just found this link. that may be it. Running chkdsk /r since it is now working. If the linked solution is the problem then I’ll post more details on it.


Did the full chkdsk which found/fixed one error. Still same problem.
Copied userinit.exe to wsaupdater.exe. still same problem.
Copied userinit.exe to System32 folder as it was missing. Booted/loaded fine.
Same Error 218 appeared with CAVS upon initiating update. Shut down CAVS then restarted. Received notice of successful update.

Thought I’d clarify what I think happen. It definitely was some sort of malware. Although I’m not sure of specifics. Because I did a number of hacks, etc. in order to get back up to windows.

One culprit include win32*.jyp. This I removed via Hijackthis and was able to get up & running then downloaded & ran Ewido which picked up 4 critical objects - droppers, trojan, worm, spawner.

Due to the mess in the registry I’m continuing to have a number of service issues. CPF is working great after uninstall/reinstall and CAVS seems to be working however not accessible through the gui.

On the plus side this has been one hell of a learning experience on the damage malware causes.

Hi everybody,
in the past 4 days I switched 3 PC from NAI to CPf and CAV solutions.
So far two of them (a standard pc with Win XP Pro SP2 and an HP notebook Win XP Home SP2) presents the same problem:

Winnt_root\System32\Hal.dll missing or corrupt:
Please re-install a copy of the above file.

Both of them began to manifested problems during e-mail download using Outlook Office XP; in general opening a new document using an MS Office product.

Both of them, just before the “Fatal Reboot” asked for many missing files to substuitute using the original Office installation CD.

Both of them was lost!
I’ve tried to save some data using Badcopy PRO and similar utilities, with scarce, or better, with no effect.

If, for the first pc I’ve thinked on an hardware (HD) fail (on a 14 months old pc!); nut after 2 identical problem on 2 so different computers in just 3 days…

CPF or CAV or both did the mess.

Hi and welcome. I can’t say for sure what your issue was but there is a new build for CAV “BETA” on the way soon. Many improvments will be made. :slight_smile:


The Third ad last of the 3 pc’s stops today … same error.
This time only CAV beta was installed on it. The personal firewall was the old Zonealarm.
So… I think I’ll wait for a stable version of CAV before to consider it again.

P.S. this last was a brand new PC, two months old; a fully patched WinXP Pro SP2 + Windows Defender and Zonealarm. Scanned ewery week with AdAware & OneCare (Microsoft Live Toolbar) . Norton Antivirus before CAV.

Surely no Wirus/Spyware/Rootkit on it!


I have a sneaking suspicion that this may be caused by CAVs autoupdater.

I just got the “missing hal.dll” error within a minute of the autoupdater completing. Luckily I had just taken an image of the boot drive about a half an hour before hand. A reboot was unsucessful, so I restored the most recently created imageand was able to boot correctly. I immediately turned off the autoupdate for CAVS and did manual update. No problems during the update or after a reboot.

I’m going to leave the autoupdate turned off for a while and see if the hal.dll issue reoccurs.

Ewen :slight_smile:

Hi, Felipe

Norton Antivirus before CAV.
Norton is not very good [CxxP in fact] ] at ininstalling itself and can cause a variety of problems.
Surely no Wirus/Spyware/Rootkit on it!
Well [i]Yes of you did and it name is [i]Symantec[/i]. ;D

Try this before a Image restore, if it happens again.


If you get an error regarding a missing or corrupt hal.dll file, it might simply be the BOOT.INI file on the root of the C: drive that is misconfigured.

Here’s what to do:

  1. Insert and boot from your Windows XP CD.
  2. At the first R=Repair option, press the R key
  3. Press the number that corresponds to the correct location for the installation of Windows you want to repair.
  4. Typically this will be #1
  5. Type bootcfg /list to show the current entries in the BOOT.INI file
  6. Type bootcfg /rebuild to repair it
  7. Take out the CD ROM and type exit[/i]

Take Care,
TheQuest 8)

Hi folks
After using Comodo Firewall (V2.3.6.81) for a while I installed the Comodo Antivirus V1.1beta. After installing and rebooting a nerving “installation”-Window popped up and installed the CAVS again.

:frowning: >:( >:( >:(
Also the scanning-engine did not work at fist: “could not initiate scan engine” or similar error message. >:( >:( >:(
After rebooting the update worked (installed some modules) and also virus-scanning worked.
But when I wanted to boot up this morning Windows (I installed Xp Pro incl. SP2 from a full licence Cd) said "can not start windows, missing /system32/HAL.DLL " >:( >:( ??? ??? :o :o
Using BART PE I could restore HAL.DLL and NTOSKRNL.EXE (windows asked about this missing file after restoring hal.dll). But some of my correctly installed programms loosened its registration (aerofly professinal deluxe, realflight G3) and mediaplayer classic wants for dsound.dll and other programms are missing other DLL’s… There was NOTHING in the quaranteen. This mess seems a DIRECT effect of this >:( >:( >:( CAVS >:( >:( >:(! What kind of programming can cause such a disaster? This is SCARY! A responsible company (is Comodo one???) should prevent downloading and installing this version and fix that disaster. Best wishes to all injured by CAVS ones and a happy 2007, Doctor T.