Can't access external HDs over network (resolved)


I use CPF v.
When I try to access my external HDs from Xbox1 it simply doesn’t work. In the firewall there’s no block alert.
It doesn’t even work when disabling the FW and D+ or even shutting of CPF completly.
With CPF v2.4 I had no problem.
All other shares are working, even my USB-Flash drive.

Please, any help appreciated


If you’re talking about an Xbox360 then I don’t believe you can access the HDD directly. If you’re talking about a modded Xbox then you most likely can only connect through an FTP program. The only way I can connect to my modded Xbox’s HDD is through FTP. I have Xbox Media Center.

I mean the old Xbox and I always could connect to external HDs. I use XBMC to stream my videos from the ext. HD connected to my PC.
It always worked until now.

Hello I solved the problem. :BNC

I looked in the “Event-Log” from Windows and there were error with the EventID 2011 saying that my IRPStackSize is too small.
I looked int the registry under this path:
There was no IRPStackSize, so I added it with the value 50 (15 = standard, but it didn’t work).
Now everything is working fine again.
I don’t know wheter CPF3 removed this value or something else.
Maybe someone else can test this.

I’ve the same problem…mmm i’m trying your suggestion. so now you can reach by ftp your xbox 1 hd? now I’ve the 2.4 installed and its work ftp to xbox.
The value in the registri is set to 12 in esadecimal…18 in decimal…

do you think that if I unistall 2.4 ad reinstall the 3.0 this kay will be deleted?

Yeah, I can access my Xbox HD from the PC and vice versa.
If you’re afraid that the Reg.key gets deleted just back it up. In Regedit just do right click on the key and select “export”.

So let me to understand better.
I’ve backupped my regkey.
Now unistalling 2.4 and installing the 3.0 this key will be automatically deleted. Now ftp to a web page works good but if you try to ftp your xbox it do not list any directory.
If i add this key value ftp local to xbox will work again….

Sorry but i’m italian and i want to understand in the better way before doing confusion in my reg.

If you say yes to me i’m going to try as soon as possible

I don’t know if 3.0 was the reason that this key got deleted. I created the reg key manually like written above and since then everything works fine.
Just try the 3.0 version and if you don’t like it you could just reinstall 2.4.
I don’t think that the reg key affects FTP. FTP works anyway. SMB share within XBMC needs that reg key.

for me ftp do not work at all connecting to xbox…its strange even if it was set in passive mode and the same software works with the 2.4

the very stange things is that nothing is in the log and the network is a trusted network…

i’d like to know if someone has my same problem.


I had the same problem. Try to change the value of IRPStackSize like I did above.
I’m not at home this week, so I can’t help you anymore, sorry.