Cannot use CD after update

Hello, I have been running CD for years. I was using v.22 up until yesterday. I ran the updater and installed v.24, opened up CD and it just sits there loading whatever page then eventually it craps out. Whats really strange is that If I open another browser and the same thing happens. Now before you go and blame my connection (which I thought initially) let me explain what I’ve done.

After the v.24 update I tried both IE and chrome and all three failed … wtf both browser worked fine before the update.

My steps.

Uninstalled v.24, ran IE9 and Chrome and both worked …
Reinstalled v.24 ran IE9 and Chrome and everything fails to load a NEW webpage
Uninstalled v.24 using CCleaner, cleared cache, directories, registry etc etc, Uninstalled Chrome, Installed IE10, Installed IceDragon … now IceDragon and IE10 work fine.
Installed CD 24 and now nothing works (IE10, IceDragon or CD 24)
Uninstalled CD 24 and now both IE10 and IceDragon (current default) work just fine.

I cannot use CD 24. Seems to be some sort of dns issue (why else would it affect the other apps).
All browsers exhibit the same issue, they start just fine but fail to load a NEW webpage. I only use secure DNS within comodo. Another irregularity is that when I close CD and open the task manager there are still 5 instances of dragon.exe running (single tab was running in cd before close) and I cannot cancel the processes. I actually have to restart before I can uninstall.

So for now I am using IceDragon which I don’t like and I am using IE10 as my backup.

Thoughts?? I would really like to use CD again.
btw, running W7 Home, 64bit

Update: I have installed CD without secure DNS and it is working correctly. Not sure why secure DNS is an issue now because I have been using it for a couple of years but something is up. My other browsers seem to be working fine.